summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-04-18 10:19:10 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-04-18 10:27:10 +0200
commit9eee541332775eba42ae292130e96f1b067d4fb1 (patch)
treed0ec30e3b3f37984b701abd94527d1da052c4b20 /dev-libs/openssl
parentphp-lib-r1.eclass: Remove @DEAD eclass (diff)
downloadgentoo-9eee541332775eba42ae292130e96f1b067d4fb1.tar.gz
gentoo-9eee541332775eba42ae292130e96f1b067d4fb1.tar.bz2
gentoo-9eee541332775eba42ae292130e96f1b067d4fb1.zip
dev-libs/openssl: Minor ebuild adjustments.
Package-Manager: Portage-2.3.30, Repoman-2.3.9
Diffstat (limited to 'dev-libs/openssl')
-rw-r--r--dev-libs/openssl/openssl-1.1.0h-r1.ebuild19
1 files changed, 10 insertions, 9 deletions
diff --git a/dev-libs/openssl/openssl-1.1.0h-r1.ebuild b/dev-libs/openssl/openssl-1.1.0h-r1.ebuild
index d0d225833b6a..6e38d19eaf54 100644
--- a/dev-libs/openssl/openssl-1.1.0h-r1.ebuild
+++ b/dev-libs/openssl/openssl-1.1.0h-r1.ebuild
@@ -3,7 +3,7 @@
EAPI="6"
-inherit eutils flag-o-matic toolchain-funcs multilib multilib-minimal
+inherit flag-o-matic toolchain-funcs multilib multilib-minimal
MY_P=${P/_/-}
DESCRIPTION="full-strength general purpose cryptography library (including SSL and TLS)"
@@ -70,7 +70,7 @@ src_prepare() {
cp -f "${WORKDIR}"/"${SOURCE12}" "${S}"/crypto/ec/ || die
cp -f "${WORKDIR}"/"${SOURCE13}" "${S}"/test/ || die
for i in "${FEDORA_PATCH[@]}" ; do
- epatch "${DISTDIR}"/"${i}"
+ eapply "${DISTDIR}"/"${i}"
done
# Also see the configure parts below:
# enable-ec \
@@ -85,7 +85,7 @@ src_prepare() {
rm -f Makefile
if ! use vanilla ; then
- epatch "${PATCHES[@]}"
+ eapply "${PATCHES[@]}"
fi
eapply_user #332661
@@ -104,7 +104,7 @@ src_prepare() {
|| die
# show the actual commands in the log
- sed -i '/^SET_X/s@=.*@=set -x@' Makefile.shared
+ sed -i '/^SET_X/s@=.*@=set -x@' Makefile.shared || die
# quiet out unknown driver argument warnings since openssl
# doesn't have well-split CFLAGS and we're making it even worse
@@ -113,7 +113,7 @@ src_prepare() {
# allow openssl to be cross-compiled
cp "${FILESDIR}"/gentoo.config-1.0.2 gentoo.config || die
- chmod a+rx gentoo.config
+ chmod a+rx gentoo.config || die
append-flags -fno-strict-aliasing
append-flags $(test-flags-CC -Wa,--noexecstack)
@@ -234,7 +234,7 @@ multilib_src_install() {
multilib_src_install_all() {
# openssl installs perl version of c_rehash by default, but
# we provide a shell version via app-misc/c_rehash
- rm "${ED}"/usr/bin/c_rehash || die
+ rm "${ED%/}"/usr/bin/c_rehash || die
dodoc CHANGES* FAQ NEWS README doc/*.txt doc/${PN}-c-indent.el
@@ -243,13 +243,13 @@ multilib_src_install_all() {
# build system: the static archives are built as PIC all the time.
# Only way around this would be to manually configure+compile openssl
# twice; once with shared lib support enabled and once without.
- use static-libs || rm -f "${ED}"/usr/lib*/lib*.a
+ use static-libs || rm -f "${ED%/}"/usr/lib*/lib*.a
# create the certs directory
keepdir ${SSL_CNF_DIR}/certs
# Namespace openssl programs to prevent conflicts with other man pages
- cd "${ED}"/usr/share/man
+ cd "${ED%/}"/usr/share/man || die
local m d s
for m in $(find . -type f | xargs grep -L '#include') ; do
d=${m%/*} ; d=${d#./} ; m=${m##*/}
@@ -264,6 +264,7 @@ multilib_src_install_all() {
for s in $(find -L ${d} -type l) ; do
s=${s##*/}
rm -f ${d}/${s}
+ # We don't want to "|| die" here
ln -s ssl-${m} ${d}/ssl-${s}
ln -s ssl-${s} ${d}/openssl-${s}
done
@@ -271,7 +272,7 @@ multilib_src_install_all() {
[[ -n $(find -L ${d} -type l) ]] && die "broken manpage links found :("
dodir /etc/sandbox.d #254521
- echo 'SANDBOX_PREDICT="/dev/crypto"' > "${ED}"/etc/sandbox.d/10openssl
+ echo 'SANDBOX_PREDICT="/dev/crypto"' > "${ED%/}"/etc/sandbox.d/10openssl
diropts -m0700
keepdir ${SSL_CNF_DIR}/private