summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Kenzelmann <gentoo@k8n.de>2020-06-29 21:31:46 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-07-19 13:43:27 +0300
commitc503507b86820daf811a1a84e09b6f27077573e0 (patch)
tree8e07d1d027e1f38ea0d040fe4f46080da2bccafe /dev-libs/pigpio
parentmedia-sound/supercollider: fix tests on 3.11.0 (diff)
downloadgentoo-c503507b86820daf811a1a84e09b6f27077573e0.tar.gz
gentoo-c503507b86820daf811a1a84e09b6f27077573e0.tar.bz2
gentoo-c503507b86820daf811a1a84e09b6f27077573e0.zip
dev-libs/pigpio: new version 77
new upstream version Signed-off-by: Daniel Kenzelmann <gentoo@k8n.de> Closes: https://github.com/gentoo/gentoo/pull/16490 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs/pigpio')
-rw-r--r--dev-libs/pigpio/Manifest1
-rw-r--r--dev-libs/pigpio/pigpio-77.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-libs/pigpio/Manifest b/dev-libs/pigpio/Manifest
index 1bc5710b0362..c743b666335a 100644
--- a/dev-libs/pigpio/Manifest
+++ b/dev-libs/pigpio/Manifest
@@ -1 +1,2 @@
DIST pigpio-76.tar.gz 2905839 BLAKE2B 7828a94fad9f110392dc114534a3b242f1f135d352885f3c4332a1d4a16f49d2fa58b57e9e3d64c2bf9b5f3bdd7e84a74775b518fc409daf75a55a87c5f3af57 SHA512 8cc1dc64ae32a07f4b6e200638065ba5fb26a94c1a730d81b64fa5f2bb9356b2b9910decb41def6932fc76f7ebd1df99a7966516ba3df9a09108de0afcd119d3
+DIST pigpio-77.tar.gz 2902866 BLAKE2B d03a97a596d5f408d29e61e8c5f727d7bca4caf8aeec63e9914b8d52bdc0d03d3d5b9ef1fdb408a6fcd72cd0b899f30eb79d02426cc83b271d71b543bf346928 SHA512 0533d18bc244d4cf487ffebdd68b9f341139e70df3a3862dc4705afefa2e3e4e2f51792a6c4a440b8ee1f111c9ae3141770b9578601bfa44e166bb438f45b80c
diff --git a/dev-libs/pigpio/pigpio-77.ebuild b/dev-libs/pigpio/pigpio-77.ebuild
new file mode 100644
index 000000000000..a47a53d9b909
--- /dev/null
+++ b/dev-libs/pigpio/pigpio-77.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1 systemd toolchain-funcs
+
+DESCRIPTION="A library for the Raspberry which allows control of the GPIOs"
+HOMEPAGE="http://abyz.me.uk/rpi/pigpio/ https://github.com/joan2937/pigpio"
+SRC_URI="https://github.com/joan2937/pigpio/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~arm"
+IUSE="python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+PATCHES=( "${FILESDIR}/${PN}-70-makefile.patch" )
+
+src_compile() {
+ emake CC="$(tc-getCC)" STRIP=: STRIPLIB=: SIZE=:
+ use python && distutils-r1_src_compile
+}
+
+src_install() {
+ emake DESTDIR="${D}" LDCONFIG=: PYTHON2=: PYTHON3=: \
+ libdir="${EPREFIX}/usr/$(get_libdir)" prefix="${EPREFIX}/usr" \
+ mandir="${EPREFIX}/usr/share/man" install
+ einstalldocs
+ newinitd "${FILESDIR}"/pigpiod.initd pigpiod
+ newconfd "${FILESDIR}"/pigpiod.confd pigpiod
+ systemd_newunit "${S}"/util/pigpiod.service pigpiod.service
+ use python && distutils-r1_src_install
+}