summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2018-08-16 16:20:21 +0300
committerAlon Bar-Lev <alonbl@gentoo.org>2018-08-16 16:20:47 +0300
commitf7a1e37b83673793482e8acee598c5a8251a2a88 (patch)
tree02f06d532d132fd00aa53f9907c942d333ff2d2d /dev-libs/pkcs11-helper/pkcs11-helper-1.25.1.ebuild
parentsys-kernel/gentoo-sources: Fix compilation error (diff)
downloadgentoo-f7a1e37b83673793482e8acee598c5a8251a2a88.tar.gz
gentoo-f7a1e37b83673793482e8acee598c5a8251a2a88.tar.bz2
gentoo-f7a1e37b83673793482e8acee598c5a8251a2a88.zip
dev-libs/pkcs11-helper: version bump
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-libs/pkcs11-helper/pkcs11-helper-1.25.1.ebuild')
-rw-r--r--dev-libs/pkcs11-helper/pkcs11-helper-1.25.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-libs/pkcs11-helper/pkcs11-helper-1.25.1.ebuild b/dev-libs/pkcs11-helper/pkcs11-helper-1.25.1.ebuild
new file mode 100644
index 000000000000..edf00dbc2add
--- /dev/null
+++ b/dev-libs/pkcs11-helper/pkcs11-helper-1.25.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit ltprune
+
+DESCRIPTION="PKCS#11 helper library"
+HOMEPAGE="https://github.com/OpenSC/pkcs11-helper"
+SRC_URI="https://github.com/OpenSC/${PN}/releases/download/${P}/${P}.tar.bz2"
+
+LICENSE="|| ( BSD GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc x86 ~x86-fbsd"
+IUSE="doc gnutls libressl nss static-libs"
+
+RDEPEND="
+ !libressl? ( >=dev-libs/openssl-0.9.7:= )
+ libressl? ( dev-libs/libressl )
+ gnutls? ( >=net-libs/gnutls-1.4.4 )
+ nss? ( dev-libs/nss )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( >=app-doc/doxygen-1.4.7 )"
+
+src_configure() {
+ econf \
+ --disable-crypto-engine-polarssl \
+ --disable-crypto-engine-mbedtls \
+ $(use_enable doc) \
+ $(use_enable gnutls crypto-engine-gnutls) \
+ $(use_enable nss crypto-engine-nss) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}