summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2015-10-05 10:39:00 +0200
committerJulian Ospald <hasufell@gentoo.org>2015-10-05 10:45:15 +0200
commit427804d3e91c13559ff4de53ef864cbc5bdcf9cd (patch)
tree318fa66c23a6b443ba65edbaba692c178fc9602a /dev-libs/pkcs11-helper
parentnet-misc/iputils: add libressl support (diff)
downloadgentoo-427804d3e91c13559ff4de53ef864cbc5bdcf9cd.tar.gz
gentoo-427804d3e91c13559ff4de53ef864cbc5bdcf9cd.tar.bz2
gentoo-427804d3e91c13559ff4de53ef864cbc5bdcf9cd.zip
dev-libs/pkcs11-helper: add libressl support
Diffstat (limited to 'dev-libs/pkcs11-helper')
-rw-r--r--dev-libs/pkcs11-helper/pkcs11-helper-1.11-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-libs/pkcs11-helper/pkcs11-helper-1.11-r1.ebuild b/dev-libs/pkcs11-helper/pkcs11-helper-1.11-r1.ebuild
new file mode 100644
index 000000000000..739b3c1153f9
--- /dev/null
+++ b/dev-libs/pkcs11-helper/pkcs11-helper-1.11-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+DESCRIPTION="PKCS#11 helper library"
+HOMEPAGE="http://www.opensc-project.org/opensc/wiki/pkcs11-helper"
+SRC_URI="mirror://sourceforge/opensc/${PN}/${P}.tar.bz2"
+
+LICENSE="|| ( BSD GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc gnutls libressl nss static-libs"
+
+RDEPEND="
+ !libressl? ( >=dev-libs/openssl-0.9.7:0 )
+ libressl? ( dev-libs/libressl )
+ gnutls? ( >=net-libs/gnutls-1.4.4 )
+ nss? ( dev-libs/nss )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( >=app-doc/doxygen-1.4.7 )"
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ $(use_enable doc) \
+ $(use_enable gnutls crypto-engine-gnutls) \
+ $(use_enable nss crypto-engine-nss) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}