summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-01-03 10:35:56 +0000
committerSam James <sam@gentoo.org>2024-01-03 10:39:55 +0000
commit58e7aa028862014e5f92ef48339b3cab59565c39 (patch)
tree48f25832372fed474dcfa51a4e8172773dcb252a /dev-libs/popt/popt-1.19-r1.ebuild
parentsys-libs/libxcrypt: pass -Wl,--undefined-version for other linkers if supported (diff)
downloadgentoo-58e7aa028862014e5f92ef48339b3cab59565c39.tar.gz
gentoo-58e7aa028862014e5f92ef48339b3cab59565c39.tar.bz2
gentoo-58e7aa028862014e5f92ef48339b3cab59565c39.zip
dev-libs/popt: pass -Wl,--undefined-version for other linkers if supported
Revbump as it's a library. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/popt/popt-1.19-r1.ebuild')
-rw-r--r--dev-libs/popt/popt-1.19-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-libs/popt/popt-1.19-r1.ebuild b/dev-libs/popt/popt-1.19-r1.ebuild
new file mode 100644
index 000000000000..58a87653a6e5
--- /dev/null
+++ b/dev-libs/popt/popt-1.19-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic multilib-minimal libtool
+
+DESCRIPTION="Parse Options - Command line parser"
+HOMEPAGE="https://github.com/rpm-software-management/popt"
+SRC_URI="http://ftp.rpm.org/${PN}/releases/${PN}-1.x/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="nls static-libs"
+
+RDEPEND="nls? ( >=virtual/libintl-0-r1[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}"
+BDEPEND="nls? ( >=sys-devel/gettext-0.19.8 )"
+
+src_prepare() {
+ default
+
+ # Unclear what the background to this is, perhaps
+ # https://gitlab.exherbo.org/exherbo/arbor/-/commit/5545d22d3493279acf7a55246179f818ef22f5fa
+ sed -i -e 's:lt-test1:test1:' tests/testit.sh || die
+
+ elibtoolize
+}
+
+multilib_src_configure() {
+ append-ldflags $(test-flags-CCLD -Wl,--undefined-version)
+
+ local myeconfargs=(
+ --disable-werror
+ $(use_enable static-libs static)
+ $(use_enable nls)
+ )
+
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ find "${ED}" -type f -name "*.la" -delete || die
+}