summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/pth
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/pth')
-rw-r--r--dev-libs/pth/Manifest1
-rw-r--r--dev-libs/pth/files/pth-2.0.5-parallelfix.patch15
-rw-r--r--dev-libs/pth/files/pth-2.0.6-ldflags.patch17
-rw-r--r--dev-libs/pth/files/pth-2.0.6-sigstack.patch22
-rw-r--r--dev-libs/pth/files/pth-2.0.7-ia64.patch30
-rw-r--r--dev-libs/pth/files/pth-2.0.7-kernel-3.patch24
-rw-r--r--dev-libs/pth/files/pth-2.0.7-parallel-install.patch12
-rw-r--r--dev-libs/pth/metadata.xml5
-rw-r--r--dev-libs/pth/pth-2.0.7-r3.ebuild50
9 files changed, 176 insertions, 0 deletions
diff --git a/dev-libs/pth/Manifest b/dev-libs/pth/Manifest
new file mode 100644
index 000000000000..23ec32d2d7d7
--- /dev/null
+++ b/dev-libs/pth/Manifest
@@ -0,0 +1 @@
+DIST pth-2.0.7.tar.gz 652640 SHA256 72353660c5a2caafd601b20e12e75d865fd88f6cf1a088b306a3963f0bc77232 SHA512 f79d74047c50e06f3198356f88647c5c1c8a04ebdd94641fc31d5ab0fd2750d86615fcb81da2f98d7ea73d012a501195d3fa09060571d18dcfdaec5d7a0ecb12 WHIRLPOOL 9b8f60823d40a8e003d3c6555d392974e3b891336a535458c133e7863abb9b6f2e731591f11ba17fed1fe1eec6c8b00ba5352cfd3a8bc2906ad4b55aa6c345f8
diff --git a/dev-libs/pth/files/pth-2.0.5-parallelfix.patch b/dev-libs/pth/files/pth-2.0.5-parallelfix.patch
new file mode 100644
index 000000000000..a305f59333f0
--- /dev/null
+++ b/dev-libs/pth/files/pth-2.0.5-parallelfix.patch
@@ -0,0 +1,15 @@
+--- Makefile.in.orig 2005-11-08 05:58:55.000000000 +1100
++++ Makefile.in 2005-11-08 06:29:02.000000000 +1100
+@@ -148,10 +148,9 @@
+
+ # be aware of libtool when building the objects
+ .SUFFIXES:
+-.SUFFIXES: .c .o .lo
+-.c.o:
++%.o: %.c $(TARGET_PREQ)
+ $(CC) -c $(CPPFLAGS) $(CFLAGS) $<
+-.c.lo:
++%.lo: %.c $(TARGET_PREQ)
+ $(LIBTOOL) --mode=compile --quiet $(CC) -c $(CPPFLAGS) $(CFLAGS) $<
+
+ # the default target
diff --git a/dev-libs/pth/files/pth-2.0.6-ldflags.patch b/dev-libs/pth/files/pth-2.0.6-ldflags.patch
new file mode 100644
index 000000000000..7a4a5ab30000
--- /dev/null
+++ b/dev-libs/pth/files/pth-2.0.6-ldflags.patch
@@ -0,0 +1,17 @@
+Index: pth-2.0.6/Makefile.in
+===================================================================
+--- pth-2.0.6.orig/Makefile.in
++++ pth-2.0.6/Makefile.in
+@@ -168,10 +168,10 @@ pth_p.h: $(S)pth_p.h.in
+
+ # build the static and possibly shared libraries
+ libpth.la: $(LOBJS)
+- $(LIBTOOL) --mode=link --quiet $(CC) -o libpth.la $(LOBJS) \
++ $(LIBTOOL) --mode=link --quiet $(CC) $(LDFLAGS) -o libpth.la $(LOBJS) \
+ -rpath $(libdir) -version-info `$(SHTOOL) version -lc -dlibtool $(_VERSION_FILE)`
+ libpthread.la: pthread.lo $(LOBJS)
+- $(LIBTOOL) --mode=link --quiet $(CC) -o libpthread.la pthread.lo $(LOBJS) \
++ $(LIBTOOL) --mode=link --quiet $(CC) $(LDFLAGS) -o libpthread.la pthread.lo $(LOBJS) \
+ -rpath $(libdir) -version-info `$(SHTOOL) version -lc -dlibtool $(_VERSION_FILE)`
+
+ # build the manual pages
diff --git a/dev-libs/pth/files/pth-2.0.6-sigstack.patch b/dev-libs/pth/files/pth-2.0.6-sigstack.patch
new file mode 100644
index 000000000000..3914dea7ac6c
--- /dev/null
+++ b/dev-libs/pth/files/pth-2.0.6-sigstack.patch
@@ -0,0 +1,22 @@
+diff -urNp pth-2.0.6.old/aclocal.m4 pth-2.0.6/aclocal.m4
+--- pth-2.0.6.old/aclocal.m4 2004-12-31 21:33:19.000000000 +0200
++++ pth-2.0.6/aclocal.m4 2006-09-20 14:46:59.000000000 +0300
+@@ -1522,6 +1522,7 @@ int main(int argc, char *argv[])
+ int sksize;
+ char result[1024];
+ int i;
++exit (1);
+ sksize = 32768;
+ skbuf = (char *)malloc(sksize*2+2*sizeof(union alltypes));
+ if (skbuf == NULL)
+diff -urNp pth-2.0.6.old/configure pth-2.0.6/configure
+--- pth-2.0.6.old/configure 2005-11-22 09:49:21.000000000 +0200
++++ pth-2.0.6/configure 2006-09-20 14:55:23.000000000 +0300
+@@ -24735,6 +24735,7 @@ int main(int argc, char *argv[])
+ int sksize;
+ char result[1024];
+ int i;
++exit (1);
+ sksize = 32768;
+ skbuf = (char *)malloc(sksize*2+2*sizeof(union alltypes));
+ if (skbuf == NULL)
diff --git a/dev-libs/pth/files/pth-2.0.7-ia64.patch b/dev-libs/pth/files/pth-2.0.7-ia64.patch
new file mode 100644
index 000000000000..8b08b82ca6c1
--- /dev/null
+++ b/dev-libs/pth/files/pth-2.0.7-ia64.patch
@@ -0,0 +1,30 @@
+# http://bugs.debian.org/225780
+diff -Naurp pth.orig/pth_sched.c pth/pth_sched.c
+--- pth.orig/pth_sched.c 2009-07-16 23:16:52.000000000 +0000
++++ pth/pth_sched.c 2009-07-16 23:20:51.000000000 +0000
+@@ -297,8 +297,15 @@ intern void *pth_scheduler(void *dummy)
+ /*
+ * Check for stack overflow
+ */
++#ifndef __ia64__
+ if (pth_current->stackguard != NULL) {
+ if (*pth_current->stackguard != 0xDEAD) {
++#else
++ /* On ia64 the stack grows down but the bottom part is used for register
++ * backing store which grows up. So we check for a meet in the middle
++ */
++ if (pth_current->mctx.uc.uc_mcontext.sc_gr[12] <= pth_current->mctx.uc.uc_mcontext.sc_ar_bsp) {
++#endif
+ pth_debug3("pth_scheduler: stack overflow detected for thread 0x%lx (\"%s\")",
+ (unsigned long)pth_current, pth_current->name);
+ /*
+@@ -324,7 +331,9 @@ intern void *pth_scheduler(void *dummy)
+ pth_current->state = PTH_STATE_DEAD;
+ kill(getpid(), SIGSEGV);
+ }
++#ifndef __ia64__
+ }
++#endif
+
+ /*
+ * If previous thread is now marked as dead, kick it out
diff --git a/dev-libs/pth/files/pth-2.0.7-kernel-3.patch b/dev-libs/pth/files/pth-2.0.7-kernel-3.patch
new file mode 100644
index 000000000000..c8a1afb369a1
--- /dev/null
+++ b/dev-libs/pth/files/pth-2.0.7-kernel-3.patch
@@ -0,0 +1,24 @@
+diff -ur pth-2.0.7.orig/aclocal.m4 pth-2.0.7/aclocal.m4
+--- pth-2.0.7.orig/aclocal.m4 2012-08-08 16:25:05.289931224 +0200
++++ pth-2.0.7/aclocal.m4 2012-08-08 16:26:45.164932424 +0200
+@@ -1074,7 +1074,7 @@
+ braindead=no
+ case "x`uname -r`" in
+ changequote(, )dnl
+- x2.[23456789]* ) ;;
++ x2.[23456789]* | x3.[0-9]* ) ;;
+ changequote([, ])
+ * ) braindead=yes ;;
+ esac
+diff -ur pth-2.0.7.orig/configure pth-2.0.7/configure
+--- pth-2.0.7.orig/configure 2012-08-08 16:25:05.289931224 +0200
++++ pth-2.0.7/configure 2012-08-08 16:27:00.391494004 +0200
+@@ -22512,7 +22512,7 @@
+ *-*-linux* )
+ braindead=no
+ case "x`uname -r`" in
+- x2.[23456789]* ) ;;
++ x2.[23456789]* | x3.[0-9]* ) ;;
+
+ * ) braindead=yes ;;
+ esac
diff --git a/dev-libs/pth/files/pth-2.0.7-parallel-install.patch b/dev-libs/pth/files/pth-2.0.7-parallel-install.patch
new file mode 100644
index 000000000000..7952cff5763c
--- /dev/null
+++ b/dev-libs/pth/files/pth-2.0.7-parallel-install.patch
@@ -0,0 +1,12 @@
+--- Makefile.in 2010-12-13 12:59:07.000000000 -0500
++++ Makefile.new 2010-12-13 13:00:22.000000000 -0500
+@@ -215,7 +215,8 @@
+
+ # install the package
+ install: all-for-install
+- @$(MAKE) $(MKFLAGS) install-dirs install-pth @INSTALL_PTHREAD@
++ @$(MAKE) $(MKFLAGS) install-dirs
++ @$(MAKE) $(MKFLAGS) install-pth @INSTALL_PTHREAD@
+ @touch .done-install >/dev/null 2>&1 || $(TRUE)
+ @$(MAKE) $(MKFLAGS) what-next
+ install-dirs:
diff --git a/dev-libs/pth/metadata.xml b/dev-libs/pth/metadata.xml
new file mode 100644
index 000000000000..d68fe974c15a
--- /dev/null
+++ b/dev-libs/pth/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>crypto</herd>
+</pkgmetadata>
diff --git a/dev-libs/pth/pth-2.0.7-r3.ebuild b/dev-libs/pth/pth-2.0.7-r3.ebuild
new file mode 100644
index 000000000000..a53c70e9d194
--- /dev/null
+++ b/dev-libs/pth/pth-2.0.7-r3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils fixheadtails libtool flag-o-matic
+
+DESCRIPTION="GNU Portable Threads"
+HOMEPAGE="http://www.gnu.org/software/pth/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~arm-linux"
+IUSE="debug static-libs"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+DOCS="ANNOUNCE AUTHORS ChangeLog NEWS README THANKS USERS"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.0.5-parallelfix.patch
+ epatch "${FILESDIR}"/${PN}-2.0.6-ldflags.patch
+ epatch "${FILESDIR}"/${PN}-2.0.6-sigstack.patch
+ epatch "${FILESDIR}"/${PN}-2.0.7-parallel-install.patch
+ epatch "${FILESDIR}"/${PN}-2.0.7-ia64.patch
+ epatch "${FILESDIR}"/${PN}-2.0.7-kernel-3.patch
+
+ ht_fix_file aclocal.m4 configure
+
+ elibtoolize
+}
+
+src_configure() {
+ # bug 350815
+ ( use arm || use sh ) && append-flags -U_FORTIFY_SOURCE
+
+ local conf
+ use debug && conf="${conf} --enable-debug" # have a bug --disable-debug and shared
+ econf \
+ ${conf} \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}