summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-04-09 16:44:49 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-04-09 16:44:49 +0200
commit7187fd497a63a2ab8e5aff8cf81ead4aeb559ed3 (patch)
treed08872bad4719b1017772ef084b2a138f9757703 /dev-libs/pugixml/pugixml-1.9.ebuild
parentdev-libs/jemalloc: fix HOMEPAGE, use github SRC_URI (diff)
downloadgentoo-7187fd497a63a2ab8e5aff8cf81ead4aeb559ed3.tar.gz
gentoo-7187fd497a63a2ab8e5aff8cf81ead4aeb559ed3.tar.bz2
gentoo-7187fd497a63a2ab8e5aff8cf81ead4aeb559ed3.zip
dev-libs/pugixml: Bump to version 1.9
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'dev-libs/pugixml/pugixml-1.9.ebuild')
-rw-r--r--dev-libs/pugixml/pugixml-1.9.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-libs/pugixml/pugixml-1.9.ebuild b/dev-libs/pugixml/pugixml-1.9.ebuild
new file mode 100644
index 000000000000..38a691d1f58f
--- /dev/null
+++ b/dev-libs/pugixml/pugixml-1.9.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+CMAKE_MAKEFILE_GENERATOR=emake
+
+inherit cmake-utils
+
+DESCRIPTION="Light-weight, simple, and fast XML parser for C++ with XPath support"
+HOMEPAGE="https://pugixml.org/ https://github.com/zeux/pugixml/"
+SRC_URI="https://github.com/zeux/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+
+src_configure() {
+ local mycmakeargs=( -DBUILD_SHARED_LIBS=ON )
+ cmake-utils_src_configure
+}