summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2019-01-08 16:32:37 -0500
committerCraig Andrews <candrews@gentoo.org>2019-01-08 19:17:16 -0500
commitdbd026854c2194db91db47b9ce489158bfc18ac4 (patch)
tree3591b606a1a0c8ee42367cb9cb3db6c67fd70178 /dev-libs/pugixml/pugixml-9999.ebuild
parentdev-libs/pugixml: Install pkg-config, EAPI=7 (diff)
downloadgentoo-dbd026854c2194db91db47b9ce489158bfc18ac4.tar.gz
gentoo-dbd026854c2194db91db47b9ce489158bfc18ac4.tar.bz2
gentoo-dbd026854c2194db91db47b9ce489158bfc18ac4.zip
dev-libs/pugixml: Add -9999 live version
Package-Manager: Portage-2.3.54, Repoman-2.3.12 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-libs/pugixml/pugixml-9999.ebuild')
-rw-r--r--dev-libs/pugixml/pugixml-9999.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-libs/pugixml/pugixml-9999.ebuild b/dev-libs/pugixml/pugixml-9999.ebuild
new file mode 100644
index 000000000000..3cc627c8675a
--- /dev/null
+++ b/dev-libs/pugixml/pugixml-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/zeux/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/zeux/${PN}/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+fi
+
+DESCRIPTION="Light-weight, simple, and fast XML parser for C++ with XPath support"
+HOMEPAGE="https://pugixml.org/ https://github.com/zeux/pugixml/"
+
+LICENSE="MIT"
+SLOT="0"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=ON
+ )
+ cmake-utils_src_configure
+}