summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-01-16 06:01:30 +1100
committerMichael Palimaka <kensington@gentoo.org>2016-01-16 06:02:02 +1100
commit376731e01492ed2dbac06db0252e8da484591b51 (patch)
treef1bdd1dca19a58a29ae4b6bfb2b282e1a2565fd8 /dev-libs/qcustomplot
parentdev-libs/qcustomplot: whitespace (diff)
downloadgentoo-376731e01492ed2dbac06db0252e8da484591b51.tar.gz
gentoo-376731e01492ed2dbac06db0252e8da484591b51.tar.bz2
gentoo-376731e01492ed2dbac06db0252e8da484591b51.zip
dev-libs/qcustomplot: version bump
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-libs/qcustomplot')
-rw-r--r--dev-libs/qcustomplot/Manifest2
-rw-r--r--dev-libs/qcustomplot/qcustomplot-1.3.2.ebuild53
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-libs/qcustomplot/Manifest b/dev-libs/qcustomplot/Manifest
index 129678571f9f..03410cebcf49 100644
--- a/dev-libs/qcustomplot/Manifest
+++ b/dev-libs/qcustomplot/Manifest
@@ -1,2 +1,4 @@
DIST qcustomplot-sharedlib-1.3.1.tar.gz 1926 SHA256 214b4dc82c612822b46976159864cc34732ebf0ce717bbe6d930760374344495 SHA512 1debdffed022dd3cd419d0a928176b6b0b1365739feaf8ca69458a9c6e16aa64c95d9b68eed2cde0699d7ab82e5dd66bcff8bbdb2f26e4a14e3186b3350342e6 WHIRLPOOL a51fd6ec8e46619a61b778656475ee2b3ff194d2b15c160246b1689f1b945160beece5a8762bf3fb1c8e9bc7f0cd570472379b0a679138d80609d6c3b38b481b
+DIST qcustomplot-sharedlib-1.3.2.tar.gz 1924 SHA256 18af836d2ac32f0dc2a4b1485c3038f4f5f3acf07550d86077ba5871e54bb269 SHA512 645d71c9d63ccd324f341778556f0b9ddceb3fee87b037c66f7ea7624973e24e292da7539861ffa1c8545cc0691a1041110b25d688f0b3d8787a44798a5e190e WHIRLPOOL d7ff5ffa460ac6b05816f1705f29ea82bbd709ca131ad3dc496abab1e718524f1dbe536dfaf726b0508143dbc76256a080fad8544c4e4412e58b980309e1aa2a
DIST qcustomplot-source-1.3.1.tar.gz 224892 SHA256 b557728956945931ff75d21c0894c52a6341850ad246811affdda8b10bbc8486 SHA512 ce5d74d7ae1fb8f4547368c712e3e6f5192cf64df9ece4b055910f0ab4c4244446b3869f078214e38bb5337e755647e07f9a111f96553172b7960ae434d7800b WHIRLPOOL c1d3a817bf389d2e64df489961f072d5b0317c321a3a5d77f5176e8200ea01dc721953a396cd63e87a8ae1ece79406b3b6e6453af0c9550272850eb4f6ac33c4
+DIST qcustomplot-source-1.3.2.tar.gz 225912 SHA256 a3649824c6d2d08efb0b54629e6ffe4cc57fa08ad9eb9f39edbb0c30b9659b51 SHA512 0e9fefd3f6e4428009428d3155b1a26e1d4b2a62567ca7812cefa67c06fa53f301229d8bd2c3abbe0fb7ddacb9a07515522ded56c0745cd31b1f85323d4499fb WHIRLPOOL fb5c59c71aee5fc95af9a75054f7a41a28eac7c70f296cf1b0dc4a58927f73b94a5b02203b520e367f673e4741959d195cebe6f50141be8157122aa249ea6c4a
diff --git a/dev-libs/qcustomplot/qcustomplot-1.3.2.ebuild b/dev-libs/qcustomplot/qcustomplot-1.3.2.ebuild
new file mode 100644
index 000000000000..985ffe7c136e
--- /dev/null
+++ b/dev-libs/qcustomplot/qcustomplot-1.3.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit qmake-utils
+
+DESCRIPTION="Qt C++ widget for plotting and data visualization"
+HOMEPAGE="http://www.qcustomplot.com/"
+SRC_URI="
+ http://www.qcustomplot.com/release/${PV}/QCustomPlot-sharedlib.tar.gz -> ${PN}-sharedlib-${PV}.tar.gz
+ http://www.qcustomplot.com/release/${PV}/QCustomPlot-source.tar.gz -> ${PN}-source-${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="qt5"
+
+RDEPEND="
+ !qt5? (
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwidgets:5
+ )
+"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${PN}-source
+
+src_prepare() {
+ default
+
+ sed \
+ -e 's:../../::g' \
+ -e '/CONFIG/s:shared.*:shared:g' \
+ "${WORKDIR}"/${PN}-sharedlib/sharedlib-compilation/sharedlib-compilation.pro > ${PN}.pro || die
+}
+
+src_configure() {
+ use qt5 && eqmake5 || eqmake4
+}
+
+src_install() {
+ dolib.so lib${PN}*
+ doheader ${PN}.h
+ dodoc changelog.txt
+}