summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/qof/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/qof/files')
-rw-r--r--dev-libs/qof/files/qof-0.8.0-remove_spurious_CFLAGS.patch57
-rw-r--r--dev-libs/qof/files/qof-0.8.8-cflags.patch36
-rw-r--r--dev-libs/qof/files/qof-0.8.8-unistd-define.patch58
-rw-r--r--dev-libs/qof/files/qof-0.8.8-unittest.patch44
-rw-r--r--dev-libs/qof/files/qof-0.8.8-yacc-build.patch69
5 files changed, 264 insertions, 0 deletions
diff --git a/dev-libs/qof/files/qof-0.8.0-remove_spurious_CFLAGS.patch b/dev-libs/qof/files/qof-0.8.0-remove_spurious_CFLAGS.patch
new file mode 100644
index 000000000000..56c217592e2f
--- /dev/null
+++ b/dev-libs/qof/files/qof-0.8.0-remove_spurious_CFLAGS.patch
@@ -0,0 +1,57 @@
+--- configure.orig 2009-06-09 19:15:07.000384982 +0200
++++ configure 2009-06-09 19:17:31.320384334 +0200
+@@ -22653,18 +22653,18 @@
+ $as_echo_n "checking what extra warning flags to pass to the C compiler... " >&6; }
+ if test ${GCC}x = yesx; then
+ warnFLAGS=
+- CFLAGS="${CFLAGS} -g2 -Wall"
++ CFLAGS="${CFLAGS}"
+ # Check whether --enable-error-on-warning was given.
+ if test "${enable_error_on_warning+set}" = set; then
+ enableval=$enable_error_on_warning; case "${enableval}" in
+- yes) warnFLAGS="${warnFLAGS} -Werror" ;;
++ yes) warnFLAGS="${warnFLAGS}" ;;
+ no) ;;
+ *) { { $as_echo "$as_me:$LINENO: error: bad value ${enableval} for --enable-error-on-warning" >&5
+ $as_echo "$as_me: error: bad value ${enableval} for --enable-error-on-warning" >&2;}
+ { (exit 1); exit 1; }; } ;;
+ esac
+ else
+- warnFLAGS="${warnFLAGS} -Werror"
++ warnFLAGS="${warnFLAGS}"
+ fi
+
+ GCC_VERSION=`${CC} -dumpversion`
+@@ -22672,10 +22672,10 @@
+ # This is gcc >= 3.x.x
+ if test `echo ${GCC_VERSION} | cut -d. -f2` -ge 4; then
+ # This is gcc >= 3.4.x
+- warnFLAGS="${warnFLAGS} -Wdeclaration-after-statement"
++ warnFLAGS="${warnFLAGS}"
+ else if test `echo ${GCC_VERSION} | cut -d. -f1` -ge 4; then
+ # This is gcc == 4.x.x
+- warnFLAGS="${warnFLAGS} -Wdeclaration-after-statement -Wno-pointer-sign"
++ warnFLAGS="${warnFLAGS}"
+ fi
+ fi
+ fi
+@@ -22693,19 +22693,6 @@
+ enableval=$enable_compile_warnings; set_compile_warnings=yes
+ fi
+
+-
+-if test "$GCC" = "yes" -a "$set_compile_warnings" != "no"; then
+- warnFLAGS="$warnFLAGS -Wcast-align -Wsign-compare \
+- -Wmissing-prototypes -Wmissing-declarations -Werror -Wmissing-include-dirs \
+- -Wstrict-prototypes -Winline -Wnested-externs -Wpointer-arith \
+- -Wmissing-field-initializers"
+-# LDFLAGS="$LDFLAGS -Wl,-z,defs"
+-fi
+-
+-
+-
+-
+-
+ DATADIR=`eval echo $datadir`
+ QSF_SCHEMA_DIR=`eval echo $DATADIR`"/xml/qof/qsf"
+
diff --git a/dev-libs/qof/files/qof-0.8.8-cflags.patch b/dev-libs/qof/files/qof-0.8.8-cflags.patch
new file mode 100644
index 000000000000..27d2172c7616
--- /dev/null
+++ b/dev-libs/qof/files/qof-0.8.8-cflags.patch
@@ -0,0 +1,36 @@
+From 1c56fc78f2a04625ae8c3aebd55236556ce28a90 Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Sun, 2 Nov 2014 12:04:24 +0100
+Subject: [PATCH 1/2] Remove some CFLAGS
+
+* Debugging level is only useful for debugging.
+* Werror is taken care of in error-on-warning configure switch.
+---
+ configure.ac | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index b38da9b..d80e7e5 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -393,7 +393,7 @@ dnl # *************************************
+ AC_MSG_CHECKING(what extra warning flags to pass to the C compiler)
+ if test ${GCC}x = yesx; then
+ warnFLAGS=
+- CFLAGS="${CFLAGS} -g2 -Wall"
++ CFLAGS="${CFLAGS} -Wall"
+ AC_ARG_ENABLE(error-on-warning,
+ [ --disable-error-on-warning
+ disable treating compile warnings as errors],
+@@ -431,7 +431,7 @@ AC_ARG_ENABLE(compile-warnings,
+
+ if test "$GCC" = "yes" -a "$set_compile_warnings" != "no"; then
+ warnFLAGS="$warnFLAGS -Wcast-align -Wsign-compare \
+- -Wmissing-prototypes -Wmissing-declarations -Werror -Wmissing-include-dirs \
++ -Wmissing-prototypes -Wmissing-declarations -Wmissing-include-dirs \
+ -Wstrict-prototypes -Winline -Wnested-externs -Wpointer-arith \
+ -Wmissing-field-initializers"
+ # LDFLAGS="$LDFLAGS -Wl,-z,defs"
+--
+2.1.2
+
diff --git a/dev-libs/qof/files/qof-0.8.8-unistd-define.patch b/dev-libs/qof/files/qof-0.8.8-unistd-define.patch
new file mode 100644
index 000000000000..c76afadb6584
--- /dev/null
+++ b/dev-libs/qof/files/qof-0.8.8-unistd-define.patch
@@ -0,0 +1,58 @@
+From f2504eacb6d5e42b28df77041ff659fded3fd1a4 Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Sun, 2 Nov 2014 12:43:31 +0100
+Subject: [PATCH 3/5] Leave yacc defines to configure
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Resulted in:
+* QA Notice: Package triggers severe warnings which indicate that it
+* may exhibit random runtime failures.
+* lexer.c:1942:9: warning: implicit declaration of function ‘isatty’
+* [-Wimplicit-function-declaration]
+---
+ configure.ac | 2 ++
+ lib/libsql/lexer.l | 2 ++
+ lib/libsql/sql_parser.h | 1 -
+ 3 files changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index d80e7e5..30ea37a 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -52,6 +52,8 @@ AC_PROG_MAKE_SET
+ AC_FUNC_MKTIME
+ AC_FUNC_STRTOD
+
++AC_CHECK_HEADERS_ONCE([unistd.h])
++
+ dnl # *****************************************
+ dnl # pkg-config check time
+ dnl # *****************************************
+diff --git a/lib/libsql/lexer.l b/lib/libsql/lexer.l
+index fa8c5d1..44d65e8 100644
+--- a/lib/libsql/lexer.l
++++ b/lib/libsql/lexer.l
+@@ -1,4 +1,6 @@
+ %{
++#include <config.h>
++
+ #include <stdio.h>
+ #include <string.h>
+ #include <stdlib.h>
+diff --git a/lib/libsql/sql_parser.h b/lib/libsql/sql_parser.h
+index 2157e5c..0eba93f 100644
+--- a/lib/libsql/sql_parser.h
++++ b/lib/libsql/sql_parser.h
+@@ -2,7 +2,6 @@
+ #define SQL_PARSER_H
+
+ #include <glib.h>
+-#define YY_NO_UNISTD_H
+
+
+ typedef struct sql_statement sql_statement;
+--
+2.1.2
+
diff --git a/dev-libs/qof/files/qof-0.8.8-unittest.patch b/dev-libs/qof/files/qof-0.8.8-unittest.patch
new file mode 100644
index 000000000000..070c37ead255
--- /dev/null
+++ b/dev-libs/qof/files/qof-0.8.8-unittest.patch
@@ -0,0 +1,44 @@
+From 21315eb014eb908ce3472fa75917412e21fcea29 Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Sun, 2 Nov 2014 12:06:39 +0100
+Subject: [PATCH 2/2] Make unittest build on demand
+
+Unittests need not be built when not run.
+Also, solves a dependency problem where libqofsql would not be built
+before sql_backend_test is linked.
+
+https://bugs.gentoo.org/show_bug.cgi?id=197999
+---
+ lib/libsql/Makefile.am | 2 +-
+ qof/test/Makefile.am | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/lib/libsql/Makefile.am b/lib/libsql/Makefile.am
+index b410689..c9534fb 100644
+--- a/lib/libsql/Makefile.am
++++ b/lib/libsql/Makefile.am
+@@ -21,7 +21,7 @@ libqofsql_la_LIBADD = ${GLIB_LIBS}
+ qofsqlincludedir = ${pkgincludedir}
+ qofsqlinclude_HEADERS = sql_parser.h
+
+-noinst_PROGRAMS = sql_parse_test
++check_PROGRAMS = sql_parse_test
+
+ EXTRA_DIST = \
+ README \
+diff --git a/qof/test/Makefile.am b/qof/test/Makefile.am
+index da7f28f..0760f45 100644
+--- a/qof/test/Makefile.am
++++ b/qof/test/Makefile.am
+@@ -65,7 +65,7 @@ test_sql_SOURCES = \
+ test-stuff.c \
+ test-sql.c
+
+-noinst_PROGRAMS = \
++check_PROGRAMS = \
+ test-book-merge \
+ test-date \
+ test-guid \
+--
+2.1.2
+
diff --git a/dev-libs/qof/files/qof-0.8.8-yacc-build.patch b/dev-libs/qof/files/qof-0.8.8-yacc-build.patch
new file mode 100644
index 000000000000..cb4f9a9c0d07
--- /dev/null
+++ b/dev-libs/qof/files/qof-0.8.8-yacc-build.patch
@@ -0,0 +1,69 @@
+From 118b7287f776b789a7c122f7c7e8a1cc1084e15e Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Sun, 2 Nov 2014 13:01:36 +0100
+Subject: [PATCH 4/5] Fix use of lex/yacc
+
+http://www.gnu.org/software/automake/manual/html_node/Yacc-and-Lex.html
+---
+ configure.ac | 1 +
+ lib/libsql/Makefile.am | 17 +++++++----------
+ 2 files changed, 8 insertions(+), 10 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 30ea37a..23865ea 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -45,6 +45,7 @@ AC_PROG_CXX
+ AC_PROG_CC
+ AC_PROG_CPP
+ AC_HEADER_STDC
++AM_PROG_LEX
+ AC_PROG_YACC
+ AC_PROG_INSTALL
+ AC_PROG_LN_S
+diff --git a/lib/libsql/Makefile.am b/lib/libsql/Makefile.am
+index c9534fb..78f26cc 100644
+--- a/lib/libsql/Makefile.am
++++ b/lib/libsql/Makefile.am
+@@ -5,9 +5,8 @@ lib_LTLIBRARIES = libqofsql.la
+ libqofsql_la_LDFLAGS= -version-info $(LIBQOFSQL_LIBRARY_VERSION)
+
+ libqofsql_la_SOURCES = \
+- parser.c \
+- parser.h \
+- lexer.c \
++ parser.y \
++ lexer.l \
+ sql_parser.c \
+ sql_parser.h \
+ mem.c \
+@@ -24,9 +23,7 @@ qofsqlinclude_HEADERS = sql_parser.h
+ check_PROGRAMS = sql_parse_test
+
+ EXTRA_DIST = \
+- README \
+- lexer.l \
+- parser.y
++ README
+
+ AM_CFLAGS = -g \
+ ${CFLAGS} \
+@@ -35,11 +32,11 @@ AM_CFLAGS = -g \
+ #INCLUDES = \
+ # -I$(includedir)
+
+-parser.c: parser.y
+- $(YACC) -v -d -o parser.c -p sql parser.y
++AM_YFLAGS = -v -d -p sql
++AM_LFLAGS = -Psql -o$@
+
+-lexer.c: lexer.l parser.c
+- $(LEX) -olexer.c -Psql lexer.l
++BUILT_SOURCES = parser.h
++CLEANFILES = $(BUILT_SOURCES)
+
+ sql_parse_test_SOURCES=sql_parse_test.c
+ # sql_parse_test_LDFLAGS = $(LIBGDA_LIBS)
+--
+2.1.2
+