summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-02-14 23:06:16 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-02-14 23:06:16 +0100
commitef833d3bff80f2cd1ea65771fbba31cee6084acf (patch)
tree664661fb6f1178ea1e60f54c66eadb42a44c9e68 /dev-libs/rapidjson
parentapp-misc/task: Drop 2.5.1-r1 (diff)
downloadgentoo-ef833d3bff80f2cd1ea65771fbba31cee6084acf.tar.gz
gentoo-ef833d3bff80f2cd1ea65771fbba31cee6084acf.tar.bz2
gentoo-ef833d3bff80f2cd1ea65771fbba31cee6084acf.zip
dev-libs/rapidjson: Drop 1.1.0 and 1.1.0-r1
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs/rapidjson')
-rw-r--r--dev-libs/rapidjson/rapidjson-1.1.0-r1.ebuild52
-rw-r--r--dev-libs/rapidjson/rapidjson-1.1.0.ebuild41
2 files changed, 0 insertions, 93 deletions
diff --git a/dev-libs/rapidjson/rapidjson-1.1.0-r1.ebuild b/dev-libs/rapidjson/rapidjson-1.1.0-r1.ebuild
deleted file mode 100644
index 89b31664240f..000000000000
--- a/dev-libs/rapidjson/rapidjson-1.1.0-r1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils
-
-DESCRIPTION="A fast JSON parser/generator for C++ with both SAX/DOM style API"
-HOMEPAGE="http://rapidjson.org/"
-
-LICENSE="MIT"
-IUSE="doc examples test"
-RESTRICT="!test? ( test )"
-SLOT="0"
-
-if [[ ${PV} == *9999 ]] ; then
- EGIT_REPO_URI="https://github.com/miloyip/rapidjson.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/miloyip/rapidjson/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 x86"
- S="${WORKDIR}/rapidjson-${PV}"
-fi
-
-DEPEND="
- doc? ( app-doc/doxygen )
- test? (
- dev-cpp/gtest
- dev-util/valgrind
- )"
-RDEPEND=""
-
-PATCHES=(
- "${FILESDIR}/${P}-gcc-7.patch"
-)
-
-src_prepare() {
- cmake-utils_src_prepare
-
- sed -i -e 's|-Werror||g' CMakeLists.txt || die
- sed -i -e 's|-Werror||g' example/CMakeLists.txt || die
-}
-
-src_configure() {
- local mycmakeargs=(
- -DRAPIDJSON_BUILD_DOC=$(usex doc)
- -DRAPIDJSON_BUILD_EXAMPLES=$(usex examples)
- -DRAPIDJSON_BUILD_TESTS=$(usex test)
- -DRAPIDJSON_BUILD_THIRDPARTY_GTEST=OFF
- )
- cmake-utils_src_configure
-}
diff --git a/dev-libs/rapidjson/rapidjson-1.1.0.ebuild b/dev-libs/rapidjson/rapidjson-1.1.0.ebuild
deleted file mode 100644
index ca44afce7199..000000000000
--- a/dev-libs/rapidjson/rapidjson-1.1.0.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils
-
-DESCRIPTION="A fast JSON parser/generator for C++ with both SAX/DOM style API"
-HOMEPAGE="http://rapidjson.org/"
-
-LICENSE="MIT"
-IUSE="doc examples test"
-RESTRICT="!test? ( test )"
-SLOT="0"
-
-if [[ ${PV} == *9999 ]] ; then
- EGIT_REPO_URI="https://github.com/miloyip/rapidjson.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/miloyip/rapidjson/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
- S="${WORKDIR}/rapidjson-${PV}"
-fi
-
-DEPEND="
- doc? ( app-doc/doxygen )
- test? (
- dev-cpp/gtest
- dev-util/valgrind
- )"
-RDEPEND=""
-
-src_configure() {
- local mycmakeargs=(
- -DRAPIDJSON_BUILD_DOC=$(usex doc)
- -DRAPIDJSON_BUILD_EXAMPLES=$(usex examples)
- -DRAPIDJSON_BUILD_TESTS=$(usex test)
- -DRAPIDJSON_BUILD_THIRDPARTY_GTEST=OFF
- )
- cmake-utils_src_configure
-}