summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/rasqal/rasqal-0.9.32.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/rasqal/rasqal-0.9.32.ebuild')
-rw-r--r--dev-libs/rasqal/rasqal-0.9.32.ebuild76
1 files changed, 76 insertions, 0 deletions
diff --git a/dev-libs/rasqal/rasqal-0.9.32.ebuild b/dev-libs/rasqal/rasqal-0.9.32.ebuild
new file mode 100644
index 000000000000..8e7340f08a04
--- /dev/null
+++ b/dev-libs/rasqal/rasqal-0.9.32.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils libtool
+
+DESCRIPTION="library that handles Resource Description Framework (RDF)"
+HOMEPAGE="http://librdf.org/rasqal/"
+SRC_URI="http://download.librdf.org/source/${P}.tar.gz"
+
+LICENSE="Apache-2.0 GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos"
+IUSE="+crypt gmp kernel_linux +mhash pcre static-libs test xml"
+
+RDEPEND=">=media-libs/raptor-2.0.14
+ kernel_linux? ( >=sys-apps/util-linux-2.19 )
+ pcre? ( dev-libs/libpcre )
+ xml? ( dev-libs/libxml2 )
+ !gmp? ( dev-libs/mpfr )
+ gmp? ( dev-libs/gmp )
+ crypt? (
+ !mhash? ( dev-libs/libgcrypt:0 )
+ mhash? ( app-crypt/mhash )
+ )"
+DEPEND="${RDEPEND}
+ >=sys-devel/bison-3
+ >=sys-devel/flex-2.5.36
+ virtual/pkgconfig
+ test? ( dev-perl/XML-DOM )"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_prepare() {
+ elibtoolize # g/fbsd .so versioning
+}
+
+src_configure() {
+ # FIXME: From 0.9.27 to .28 --with-random-approach= was introduced, do we
+ # need a logic for it? Perhaps for dev-libs/gmp?
+
+ local regex=posix
+ local decimal=mpfr
+ local digest=internal
+ local uuid=internal
+
+ use pcre && regex=pcre
+ use gmp && decimal=gmp
+ use kernel_linux && uuid=libuuid
+
+ if use crypt; then
+ digest=gcrypt
+ use mhash && digest=mhash
+ fi
+
+ econf \
+ $(use_enable pcre) \
+ $(use_enable static-libs static) \
+ $(use_enable xml xml2) \
+ --with-regex-library=${regex} \
+ --with-digest-library=${digest} \
+ --with-uuid-library=${uuid} \
+ --with-decimal=${decimal} \
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
+}
+
+src_install() {
+ default
+ dohtml {NEWS,README,RELEASE}.html
+ prune_libtool_files --all
+
+ # http://bugs.gentoo.org/467768
+ local _rdocdir=/usr/share/doc/${PF}/html/${PN}
+ [[ -d ${ED}/${_rdocdir} ]] && dosym ${_rdocdir} /usr/share/gtk-doc/html/${PN}
+}