summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-03-26 20:06:42 +0100
committerConrad Kostecki <conikost@gentoo.org>2021-03-26 20:45:23 +0100
commit591a9cc41b941bcb320871a36c8a2b8622555957 (patch)
treec15d735795daf77957f4ee0130956622ba3e21d3 /dev-libs/redland-bindings
parentnet-dns/dnsdist: drop old version (diff)
downloadgentoo-591a9cc41b941bcb320871a36c8a2b8622555957.tar.gz
gentoo-591a9cc41b941bcb320871a36c8a2b8622555957.tar.bz2
gentoo-591a9cc41b941bcb320871a36c8a2b8622555957.zip
dev-libs/redland-bindings: drop old version
Dropping old version, which does not support slotted lua. Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-libs/redland-bindings')
-rw-r--r--dev-libs/redland-bindings/redland-bindings-1.0.17.1-r1.ebuild130
1 files changed, 0 insertions, 130 deletions
diff --git a/dev-libs/redland-bindings/redland-bindings-1.0.17.1-r1.ebuild b/dev-libs/redland-bindings/redland-bindings-1.0.17.1-r1.ebuild
deleted file mode 100644
index ca8b6ee1e90e..000000000000
--- a/dev-libs/redland-bindings/redland-bindings-1.0.17.1-r1.ebuild
+++ /dev/null
@@ -1,130 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-USE_PHP="php7-2 php7-3 php7-4"
-PHP_EXT_ECONF_ARGS="--with-php=yes --without-lua --without-perl --without-python --without-ruby"
-PHP_EXT_NAME="redland"
-PHP_EXT_OPTIONAL_USE="php"
-PHP_EXT_SKIP_PATCHES="yes"
-PHP_EXT_SKIP_PHPIZE="yes"
-
-inherit php-ext-source-r3 python-single-r1 autotools
-
-DESCRIPTION="Language bindings for Redland"
-HOMEPAGE="http://librdf.org/bindings/"
-SRC_URI="http://download.librdf.org/source/${P}.tar.gz"
-
-LICENSE="Apache-2.0 GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 sparc x86 ~x86-linux"
-IUSE="lua perl python php ruby test"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-RESTRICT="!test? ( test )"
-
-BDEPEND="sys-apps/sed
- virtual/pkgconfig"
-
-RDEPEND=">=dev-libs/redland-1.0.14
- lua? ( >=dev-lang/lua-5.1:0= )
- perl? ( dev-lang/perl:= )
- python? ( ${PYTHON_DEPS} )
- ruby? ( dev-lang/ruby:* dev-ruby/log4r )
- php? (
- php_targets_php7-2? ( dev-lang/php:7.2[-threads] )
- php_targets_php7-3? ( dev-lang/php:7.3[-threads] )
- php_targets_php7-4? ( dev-lang/php:7.4[-threads] )
- )"
-
-DEPEND="${RDEPEND}
- >=dev-lang/swig-2
- test? (
- >=dev-libs/redland-1.0.14[berkdb]
- )"
-
-PATCHES=(
- "${FILESDIR}"/${P}-bool.patch
- "${FILESDIR}"/${PN}-1.0.17.1-php-config-r1.patch
- "${FILESDIR}"/${PN}-1.0.17.1-add-PHP7-support.patch
-)
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- default
-
- eautoreconf
-
- use php && php-ext-source-r3_src_prepare
-}
-
-src_configure() {
- if use lua || use perl || use python || use ruby ; then
- econf \
- $(use_with lua) \
- $(use_with perl) \
- $(use_with python) \
- --without-php \
- $(use_with ruby)
- fi
-
- use php && php-ext-source-r3_src_configure
-}
-
-src_compile() {
- if use lua || use perl || use python || use ruby ; then
- default
- fi
-
- use php && php-ext-source-r3_src_compile
-}
-
-src_test() {
- if use lua || use perl || use python || use ruby ; then
- default
- fi
-
- if use php ; then
- local slot
- for slot in $(php_get_slots) ; do
- php_init_slot_env "${slot}"
- cd php || die
- ${PHPCLI} -v
- ${PHPCLI} -d "extension=./${PHP_EXT_NAME}.so" -f test.php || die "PHP tests for ${slot} failed!"
- cd "${S}" || die
- done
- fi
-}
-
-src_install() {
- if use lua || use perl || use python || use ruby ; then
- emake DESTDIR="${D}" INSTALLDIRS=vendor luadir=/usr/$(get_libdir)/lua/5.1 install
- fi
-
- if use perl; then
- find "${ED}" -type f -name perllocal.pod -delete
- find "${ED}" -depth -mindepth 1 -type d -empty -delete
- fi
-
- use python && python_optimize
-
- if use php; then
- local slot
- for slot in $(php_get_slots); do
- php_init_slot_env "${slot}"
- exeinto "${EXT_DIR#$EPREFIX}"
- doexe "php/${PHP_EXT_NAME}.so"
- done
-
- php-ext-source-r3_createinifiles
- fi
-
- local DOCS=( AUTHORS ChangeLog NEWS README TODO )
- local HTML_DOCS=( {NEWS,README,RELEASE,TODO}.html )
- einstalldocs
-}