summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2019-12-29 17:02:42 -0500
committerCraig Andrews <candrews@gentoo.org>2019-12-29 17:21:54 -0500
commit1bef97970aed14818f86fd57de801afbf0444085 (patch)
tree51237f572c5ec1557e325bbaff37261bda7a6ab6 /dev-libs/rocr-runtime
parentvirtual/wireguard: drop HOMEPAGE to fix QA issue (diff)
downloadgentoo-1bef97970aed14818f86fd57de801afbf0444085.tar.gz
gentoo-1bef97970aed14818f86fd57de801afbf0444085.tar.bz2
gentoo-1bef97970aed14818f86fd57de801afbf0444085.zip
dev-libs/rocr-runtime: 3.0.0 version bump
Closes: https://github.com/gentoo/gentoo/pull/14148/ Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-libs/rocr-runtime')
-rw-r--r--dev-libs/rocr-runtime/Manifest1
-rw-r--r--dev-libs/rocr-runtime/files/rocr-runtime-3.0.0-cmake-install-paths.patch45
-rw-r--r--dev-libs/rocr-runtime/rocr-runtime-3.0.0.ebuild37
3 files changed, 83 insertions, 0 deletions
diff --git a/dev-libs/rocr-runtime/Manifest b/dev-libs/rocr-runtime/Manifest
index 81684befba71..49064ebf53be 100644
--- a/dev-libs/rocr-runtime/Manifest
+++ b/dev-libs/rocr-runtime/Manifest
@@ -4,3 +4,4 @@ DIST rocr-runtime-2.6.0.tar.gz 318296 BLAKE2B c04e04db32f650def8a7973fa73f0c0e9b
DIST rocr-runtime-2.7.0.tar.gz 321669 BLAKE2B 99f7a62019aaa893ff032a7ed492720c1d0d8fc2c8a730f2e6833d1ad34af57e1045ed480a7d5ba72123bebfa6accd6282be4299bf94d77404adc5bbc9d13624 SHA512 46926a711665df4e232a6dcbcb1f67a4a133bffac927b70404e3cefe624be31dfc5ffea49ae9b834076cfcdf94a6e61b6804af6aed75f433e1842c980bc6e54d
DIST rocr-runtime-2.8.0.tar.gz 324868 BLAKE2B 5c46ffec7482e09032c67270a352543465f9f8a0a7c45e9884c37104e9e12a7e4dccb60bf3904d1398ffc00d9e934fc055190ba9ba4c1104bdb83be6c758eded SHA512 428b7d1d17a82c841a4d9a2c163670464416afa3ca3c579cc63ee712880940c0150e365922ffdafa44ee81fb76295cc19b66a1a4cb0a7e9a366f56782d826061
DIST rocr-runtime-2.9.0.tar.gz 323220 BLAKE2B 7e6338185f23011ed4105c6797431677e657c6fc198f83399daab4d3b2d3333ebd6e86c0d669bf794f984ea0346b8e528449eb5d81aff2ecf3f1871663458df6 SHA512 fa68fde0f79651956096ee506ff8b6760a9623e7d9cb099229b3951b7434bed5b501a3c6785c5767902c7dbf6c478ada5d2c2a5c5984063f0d0d0db8bca2bda2
+DIST rocr-runtime-3.0.0.tar.gz 327908 BLAKE2B 0d95ecc22d27e470dd46f02aca012c59e8d0b0bd76de21133a1198d2daa75547600d95ea6c3a3771da36ce3fdf5e197b40ff68543b71adf36d33079a9d9496ab SHA512 e1a1eeec67bca02defc6f502e94dab71e48833737cc0f45552781c5b0cc36bff9147b2c477d6c2c3c9bd25654569ad1d91cd06aa81fcf412657a489cb56c5674
diff --git a/dev-libs/rocr-runtime/files/rocr-runtime-3.0.0-cmake-install-paths.patch b/dev-libs/rocr-runtime/files/rocr-runtime-3.0.0-cmake-install-paths.patch
new file mode 100644
index 000000000000..29429d0c4807
--- /dev/null
+++ b/dev-libs/rocr-runtime/files/rocr-runtime-3.0.0-cmake-install-paths.patch
@@ -0,0 +1,45 @@
+https://github.com/RadeonOpenCompute/ROCR-Runtime/pull/51
+
+From 09a835e8de2d88e917328a78765a1db423d21920 Mon Sep 17 00:00:00 2001
+From: Craig Andrews <candrews@integralblue.com>
+Date: Sun, 29 Dec 2019 16:57:00 -0500
+Subject: [PATCH] Correctly install the library into the system
+
+Install to standard locations in /usr/{lib,include}/lib (as opposed to /usr/hsa/{lib,include}/hsa)
+Use CMAKE_INSTALL_LIBDIR and CMAKE_INSTALL_INCLUDEDIR from GNUInstallDirs instead of using "lib" and "include"
+---
+ CMakeLists.txt | 13 +++----------
+ 1 file changed, 3 insertions(+), 10 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index f292182..7474dd2 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -61,6 +61,7 @@ endif() # if (ROCM_CCACHE_BUILD)
+
+ list ( APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake_modules" )
+ include ( utils )
++include ( GNUInstallDirs )
+ include ( hsa_common )
+
+ ## Find LibElf
+@@ -176,17 +177,9 @@ endif ()
+ set_property ( TARGET ${CORE_RUNTIME_TARGET} PROPERTY VERSION "${SO_VERSION_STRING}" )
+ set_property ( TARGET ${CORE_RUNTIME_TARGET} PROPERTY SOVERSION "${SO_MAJOR}" )
+
+-## Create symlinks for legacy packaging and install
+-add_custom_target ( hsa_include_link ALL WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR} COMMAND ${CMAKE_COMMAND} -E create_symlink ../hsa/include/hsa hsa_include_link )
+-add_custom_target ( hsa_lib_link ALL WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR} COMMAND ${CMAKE_COMMAND} -E create_symlink ../hsa/lib/${CORE_RUNTIME_LIBRARY}.so ${CORE_RUNTIME_LIBRARY}-link.so )
+-add_custom_target ( hsa_lib_link2 ALL WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR} COMMAND ${CMAKE_COMMAND} -E create_symlink ../hsa/lib/${CORE_RUNTIME_LIBRARY}.so.${SO_MAJOR} ${CORE_RUNTIME_LIBRARY}-link.so.${SO_MAJOR} )
+-
+ ## Set install information
+-install ( TARGETS ${CORE_RUNTIME_TARGET} LIBRARY DESTINATION hsa/lib )
+-install ( DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/inc/ DESTINATION hsa/include/hsa )
+-install ( FILES ${CMAKE_CURRENT_BINARY_DIR}/hsa_include_link DESTINATION include PERMISSIONS OWNER_WRITE OWNER_READ RENAME hsa )
+-install ( FILES ${CMAKE_CURRENT_BINARY_DIR}/${CORE_RUNTIME_LIBRARY}-link.so DESTINATION lib PERMISSIONS OWNER_WRITE OWNER_READ RENAME ${CORE_RUNTIME_LIBRARY}.so )
+-install ( FILES ${CMAKE_CURRENT_BINARY_DIR}/${CORE_RUNTIME_LIBRARY}-link.so.${SO_MAJOR} DESTINATION lib PERMISSIONS OWNER_WRITE OWNER_READ RENAME ${CORE_RUNTIME_LIBRARY}.so.${SO_MAJOR} )
++install ( TARGETS ${CORE_RUNTIME_TARGET} LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR} )
++install ( DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/inc/ DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/hsa )
+
+ ## Packaging directives
+ set ( CPACK_GENERATOR "DEB;RPM" CACHE STRING "Package types to build")
diff --git a/dev-libs/rocr-runtime/rocr-runtime-3.0.0.ebuild b/dev-libs/rocr-runtime/rocr-runtime-3.0.0.ebuild
new file mode 100644
index 000000000000..a0096a72495c
--- /dev/null
+++ b/dev-libs/rocr-runtime/rocr-runtime-3.0.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/RadeonOpenCompute/ROCR-Runtime/"
+ inherit git-r3
+ S="${WORKDIR}/${P}/src"
+else
+ SRC_URI="https://github.com/RadeonOpenCompute/ROCR-Runtime/archive/roc-${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/ROCR-Runtime-roc-${PV}/src"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Radeon Open Compute Runtime"
+HOMEPAGE="https://github.com/RadeonOpenCompute/ROCR-Runtime"
+PATCHES=(
+ "${FILESDIR}/${PN}-3.0.0-cmake-install-paths.patch"
+)
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+IUSE="nonfree"
+
+COMMON_DEPEND="sys-process/numactl"
+RDEPEND="${COMMON_DEPEND}
+ nonfree? ( dev-libs/hsa-ext-rocr )"
+DEPEND="${COMMON_DEPEND}
+ >=dev-libs/roct-thunk-interface-${PV}"
+
+src_prepare() {
+ sed -e "s:get_version ( \"1.0.0\" ):get_version ( \"${PV}\" ):" -i CMakeLists.txt || die
+ cmake-utils_src_prepare
+}