summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYiyangWu <xgreenlandforwyy@gmail.com>2021-08-19 21:40:58 +0800
committerCraig Andrews <candrews@gentoo.org>2021-08-19 15:46:22 -0400
commit7576c644d59a9392b72b4234030c531d58359c44 (patch)
tree300f05397f38b616960ee68c3407446717e2ceae /dev-libs/rocr-runtime
parentdev-libs/roct-thunk-interface: bump version to 4.3.0 (diff)
downloadgentoo-7576c644d59a9392b72b4234030c531d58359c44.tar.gz
gentoo-7576c644d59a9392b72b4234030c531d58359c44.tar.bz2
gentoo-7576c644d59a9392b72b4234030c531d58359c44.zip
dev-libs/rocr-runtime: bump version to 4.3.0
remove the replacement of get_version in CMakeLists.txt, which is redundant in 4.3.0 (the sed command does not change anything). Detect no bug after the removal. Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Yiyang Wu <xgreenlandforwyy@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/22030 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-libs/rocr-runtime')
-rw-r--r--dev-libs/rocr-runtime/Manifest1
-rw-r--r--dev-libs/rocr-runtime/rocr-runtime-4.3.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-libs/rocr-runtime/Manifest b/dev-libs/rocr-runtime/Manifest
index 418f9e35e908..36efcbb03efe 100644
--- a/dev-libs/rocr-runtime/Manifest
+++ b/dev-libs/rocr-runtime/Manifest
@@ -4,3 +4,4 @@ DIST rocr-runtime-3.9.0.tar.gz 691645 BLAKE2B c90cdba93be510532a65ebfd69322972c6
DIST rocr-runtime-4.0.0.tar.gz 691835 BLAKE2B 328f7ea54767294036f435894d63354694447d964753de8b58b70ba5ae5f83561e5cda506890b43c80bdc480b1781d246ee77d5a0b08f74c5eb52d1ac5e8ddda SHA512 c95316cd8f221caee84f644e00b2b08d447b75ae4e5fe1871fa2ac6a879da57def497babfcabcaeb988d92421c165070e47d9fe846640b871249d66c82f82bea
DIST rocr-runtime-4.1.0.tar.gz 698452 BLAKE2B fb1ca1219d2c59db4d8bff414f40eaf6e7cec899a70ed930ce3dc6e2906a173db4823ac4c445fc57cc297a932f83b140747e35ee3d77fa0ed11cec97718fdc47 SHA512 d2162f431adf0b8f8ae5bbfe43ed389d4d94db5897fc8d1b4eb9b152a74f605fa2cf5d80175e6f9cda45e39803ededef6151aa9bdea99f38a16ca2dea29588d9
DIST rocr-runtime-4.2.0.tar.gz 701445 BLAKE2B 901c256bae823861813a7afdbd3e9f80b6f86cf2c7002815e04c762cef241a9f32274093067c97578e05fdf5c4e699287b7835d00917cb4997302c455e5d593a SHA512 44a798efd0121c7107f3f5df868eb83d0ff9aad1e11c01105d5852bef159c019db6d2aeebe02e8e187dc45a2542d72f145fb5390b27abf64e0b427e192772d6c
+DIST rocr-runtime-4.3.0.tar.gz 709075 BLAKE2B 6856681bd3d56827e517f76838886f793f4d709562c2c7c4f480ef5786c5a5fac25654032b80d565ab5da241f76329d39ab3189daa4806b8cf1564d9f08a837d SHA512 749a8f84a302f7ed518f87688f68cc2a094eea2d104cddc25b3e5d98ddf6e534285750828ca654976054bbf986a61735e17ad211505557671627e44f6831dc0c
diff --git a/dev-libs/rocr-runtime/rocr-runtime-4.3.0.ebuild b/dev-libs/rocr-runtime/rocr-runtime-4.3.0.ebuild
new file mode 100644
index 000000000000..c1f5f5a3a07b
--- /dev/null
+++ b/dev-libs/rocr-runtime/rocr-runtime-4.3.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/RadeonOpenCompute/ROCR-Runtime/"
+ inherit git-r3
+ S="${WORKDIR}/${P}/src"
+else
+ SRC_URI="https://github.com/RadeonOpenCompute/ROCR-Runtime/archive/rocm-${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/ROCR-Runtime-rocm-${PV}/src"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Radeon Open Compute Runtime"
+HOMEPAGE="https://github.com/RadeonOpenCompute/ROCR-Runtime"
+PATCHES=(
+ "${FILESDIR}/${PN}-4.1.0-cmake-install-paths.patch"
+)
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+
+COMMON_DEPEND="sys-process/numactl
+ dev-libs/elfutils:="
+RDEPEND="${COMMON_DEPEND}"
+DEPEND="${COMMON_DEPEND}
+ >=dev-libs/roct-thunk-interface-${PV}
+ >=dev-libs/rocm-device-libs-${PV}"
+BDEPEND="app-editors/vim-core"
+ # vim-core is needed for "xxd"
+
+src_prepare() {
+ # ... otherwise system llvm/clang is used ...
+ sed -e "s:find_package(Clang REQUIRED HINTS \${CMAKE_INSTALL_PREFIX}/llvm \${CMAKE_PREFIX_PATH}/llvm PATHS /opt/rocm/llvm ):find_package(Clang REQUIRED HINTS ${EPREFIX}/usr/lib/llvm/roc ):" -i image/blit_src/CMakeLists.txt || die
+
+ # Gentoo installs "*.bc" to "/usr/lib" instead of a "[path]/bitcode" directory ...
+ sed -e "s:/opt/rocm/amdgcn/bitcode:${EPREFIX}/usr/lib/amdgcn/bitcode:" -i image/blit_src/CMakeLists.txt || die
+
+ cmake_src_prepare
+}