summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2021-04-27 09:16:01 -0400
committerCraig Andrews <candrews@gentoo.org>2021-04-27 09:16:19 -0400
commite13c75c126c0b488d05e7bbe623209a440d32e46 (patch)
treea101e75a865863ccb458c9b459adb89327a317cb /dev-libs/rocr-runtime
parentsys-devel/llvm-roc: Remove PDEPEND="dev-libs/rocr-runtime" (diff)
downloadgentoo-e13c75c126c0b488d05e7bbe623209a440d32e46.tar.gz
gentoo-e13c75c126c0b488d05e7bbe623209a440d32e46.tar.bz2
gentoo-e13c75c126c0b488d05e7bbe623209a440d32e46.zip
dev-libs/rocr-runtime: Depend on sys-devel/llvm-roc
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-libs/rocr-runtime')
-rw-r--r--dev-libs/rocr-runtime/rocr-runtime-3.10.0.ebuild5
-rw-r--r--dev-libs/rocr-runtime/rocr-runtime-3.8.0.ebuild5
-rw-r--r--dev-libs/rocr-runtime/rocr-runtime-3.9.0.ebuild5
-rw-r--r--dev-libs/rocr-runtime/rocr-runtime-4.0.0.ebuild5
-rw-r--r--dev-libs/rocr-runtime/rocr-runtime-4.1.0.ebuild3
-rw-r--r--dev-libs/rocr-runtime/rocr-runtime-9999.ebuild3
6 files changed, 16 insertions, 10 deletions
diff --git a/dev-libs/rocr-runtime/rocr-runtime-3.10.0.ebuild b/dev-libs/rocr-runtime/rocr-runtime-3.10.0.ebuild
index 22be187e6afe..256f7ffb9e4a 100644
--- a/dev-libs/rocr-runtime/rocr-runtime-3.10.0.ebuild
+++ b/dev-libs/rocr-runtime/rocr-runtime-3.10.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -25,7 +25,8 @@ LICENSE="MIT"
SLOT="0/$(ver_cut 1-2)"
COMMON_DEPEND="sys-process/numactl
- dev-libs/elfutils:="
+ dev-libs/elfutils:=
+ >=sys-devel/llvm-roc-${PV}"
RDEPEND="${COMMON_DEPEND}"
DEPEND="${COMMON_DEPEND}
>=dev-libs/roct-thunk-interface-${PV}
diff --git a/dev-libs/rocr-runtime/rocr-runtime-3.8.0.ebuild b/dev-libs/rocr-runtime/rocr-runtime-3.8.0.ebuild
index a53ba934d9c8..4c5db671ec1a 100644
--- a/dev-libs/rocr-runtime/rocr-runtime-3.8.0.ebuild
+++ b/dev-libs/rocr-runtime/rocr-runtime-3.8.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -25,7 +25,8 @@ LICENSE="MIT"
SLOT="0/$(ver_cut 1-2)"
COMMON_DEPEND="sys-process/numactl
- dev-libs/elfutils:="
+ dev-libs/elfutils:=
+ >=sys-devel/llvm-roc-${PV}"
RDEPEND="${COMMON_DEPEND}"
DEPEND="${COMMON_DEPEND}
>=dev-libs/roct-thunk-interface-${PV}
diff --git a/dev-libs/rocr-runtime/rocr-runtime-3.9.0.ebuild b/dev-libs/rocr-runtime/rocr-runtime-3.9.0.ebuild
index 22be187e6afe..256f7ffb9e4a 100644
--- a/dev-libs/rocr-runtime/rocr-runtime-3.9.0.ebuild
+++ b/dev-libs/rocr-runtime/rocr-runtime-3.9.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -25,7 +25,8 @@ LICENSE="MIT"
SLOT="0/$(ver_cut 1-2)"
COMMON_DEPEND="sys-process/numactl
- dev-libs/elfutils:="
+ dev-libs/elfutils:=
+ >=sys-devel/llvm-roc-${PV}"
RDEPEND="${COMMON_DEPEND}"
DEPEND="${COMMON_DEPEND}
>=dev-libs/roct-thunk-interface-${PV}
diff --git a/dev-libs/rocr-runtime/rocr-runtime-4.0.0.ebuild b/dev-libs/rocr-runtime/rocr-runtime-4.0.0.ebuild
index 22be187e6afe..256f7ffb9e4a 100644
--- a/dev-libs/rocr-runtime/rocr-runtime-4.0.0.ebuild
+++ b/dev-libs/rocr-runtime/rocr-runtime-4.0.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -25,7 +25,8 @@ LICENSE="MIT"
SLOT="0/$(ver_cut 1-2)"
COMMON_DEPEND="sys-process/numactl
- dev-libs/elfutils:="
+ dev-libs/elfutils:=
+ >=sys-devel/llvm-roc-${PV}"
RDEPEND="${COMMON_DEPEND}"
DEPEND="${COMMON_DEPEND}
>=dev-libs/roct-thunk-interface-${PV}
diff --git a/dev-libs/rocr-runtime/rocr-runtime-4.1.0.ebuild b/dev-libs/rocr-runtime/rocr-runtime-4.1.0.ebuild
index caacf00b4bf8..38fc7decb01f 100644
--- a/dev-libs/rocr-runtime/rocr-runtime-4.1.0.ebuild
+++ b/dev-libs/rocr-runtime/rocr-runtime-4.1.0.ebuild
@@ -26,7 +26,8 @@ SLOT="0/$(ver_cut 1-2)"
IUSE="debug"
COMMON_DEPEND="sys-process/numactl
- dev-libs/elfutils:="
+ dev-libs/elfutils:=
+ >=sys-devel/llvm-roc-${PV}"
RDEPEND="${COMMON_DEPEND}"
DEPEND="${COMMON_DEPEND}
>=dev-libs/roct-thunk-interface-${PV}
diff --git a/dev-libs/rocr-runtime/rocr-runtime-9999.ebuild b/dev-libs/rocr-runtime/rocr-runtime-9999.ebuild
index caacf00b4bf8..38fc7decb01f 100644
--- a/dev-libs/rocr-runtime/rocr-runtime-9999.ebuild
+++ b/dev-libs/rocr-runtime/rocr-runtime-9999.ebuild
@@ -26,7 +26,8 @@ SLOT="0/$(ver_cut 1-2)"
IUSE="debug"
COMMON_DEPEND="sys-process/numactl
- dev-libs/elfutils:="
+ dev-libs/elfutils:=
+ >=sys-devel/llvm-roc-${PV}"
RDEPEND="${COMMON_DEPEND}"
DEPEND="${COMMON_DEPEND}
>=dev-libs/roct-thunk-interface-${PV}