summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-05-01 09:55:21 -0400
committerMatt Turner <mattst88@gentoo.org>2021-05-01 10:06:55 -0400
commit991344348e6f44b89fa02d5a026f40d944f38b4b (patch)
treed7cbb933d1ce9bffd9e30ae656fcdaaf3757e08a /dev-libs/satyr
parentsys-auth/libfprint: Stabilize 1.90.7 arm64, #787053 (diff)
downloadgentoo-991344348e6f44b89fa02d5a026f40d944f38b4b.tar.gz
gentoo-991344348e6f44b89fa02d5a026f40d944f38b4b.tar.bz2
gentoo-991344348e6f44b89fa02d5a026f40d944f38b4b.zip
dev-libs/satyr: Version bump to 0.37
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-libs/satyr')
-rw-r--r--dev-libs/satyr/Manifest1
-rw-r--r--dev-libs/satyr/satyr-0.37.ebuild100
2 files changed, 101 insertions, 0 deletions
diff --git a/dev-libs/satyr/Manifest b/dev-libs/satyr/Manifest
index b78f27a448fc..66c5c71c375b 100644
--- a/dev-libs/satyr/Manifest
+++ b/dev-libs/satyr/Manifest
@@ -1 +1,2 @@
DIST satyr-0.31.tar.gz 428719 BLAKE2B 23c6ea53db261fee366566101c2b0f1e23cf530728332fe752897ee982ffac057b98de3d9a52dbfc64932cdb73aaff7e35c976e7a55e30b4417f3880782f9125 SHA512 a5aafa1ca5f85a0a817c6fa9a3b428672c9f4f529fb7d73a3e819cc836b78c01a0ca44b47317fcdd4a40dc6386688a450bd78564b6e466091cdc9a2c730c3fda
+DIST satyr-0.37.tar.gz 433804 BLAKE2B 3d243f1ea4254767740fbab4aff5d42537e4ec7d6cfded9af36b022bbcb76a08172f36cac98fb9d199aefcf3f7fefd443e3573426f5cd84eb5bf404d36dbfb29 SHA512 ac67c931dcf3031b0fabca6d0be572381b8027da588add85d22ba7058304a0ec457379be77cd99ce0607ceac35a45d42b6c293751f7471797cc9eba280ce91b5
diff --git a/dev-libs/satyr/satyr-0.37.ebuild b/dev-libs/satyr/satyr-0.37.ebuild
new file mode 100644
index 000000000000..cd25deaf9e49
--- /dev/null
+++ b/dev-libs/satyr/satyr-0.37.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit autotools multiprocessing python-r1
+
+DESCRIPTION="Satyr is a collection of low-level algorithms for program failure processing"
+HOMEPAGE="https://github.com/abrt/satyr"
+SRC_URI="https://github.com/abrt/${PN}/archive/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0/4"
+
+IUSE="python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )
+ >=dev-libs/elfutils-0.158
+ dev-libs/glib:2
+ dev-libs/json-c:=
+ dev-libs/nettle:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ dev-util/gperf
+"
+
+src_prepare() {
+ default
+ ./gen-version || die # Needs to be run before full autoreconf
+ eautoreconf
+ use python && python_copy_sources
+}
+
+src_configure() {
+ use python && python_setup
+
+ local myargs=(
+ --localstatedir="${EPREFIX}/var"
+ --without-rpm
+ $(usex python "--with-python3" "--without-python3")
+ )
+
+ if use python; then
+ python_configure() {
+ econf "${myargs[@]}"
+ }
+ python_foreach_impl run_in_build_dir python_configure
+ else
+ econf "${myargs[@]}"
+ fi
+}
+
+src_compile() {
+ if use python; then
+ python_foreach_impl run_in_build_dir default
+ else
+ default
+ fi
+
+}
+
+src_test() {
+ local extra_args
+
+ # In order to pass --jobs to the test runner
+ run_tests() {
+ cd tests || die
+ emake testsuite
+ ./testsuite --jobs=$(makeopts_jobs) ${extra_args[@]} $@
+
+ # Only run the python bindings tests for other python impls
+ extra_args=('-k' 'python3_bindings.*')
+ }
+
+ if use python; then
+ python_foreach_impl run_in_build_dir run_tests
+ else
+ run_tests SKIP_PYTHON3=yes
+ fi
+}
+
+src_install() {
+ if use python; then
+ python_install() {
+ default
+ python_optimize
+ }
+ python_foreach_impl run_in_build_dir python_install
+ else
+ default
+ fi
+
+ find "${D}" -name '*.la' -type f -delete || die
+}