summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2018-10-19 19:12:09 +0300
committerAlon Bar-Lev <alonbl@gentoo.org>2018-10-19 19:12:28 +0300
commita4cb36623d37346ba2539f66ae6cbb0ecb0c27f2 (patch)
tree0378269eba6e743a750fe50782286035d77460d1 /dev-libs/softhsm/softhsm-2.5.0.ebuild
parentdev-perl/Importer: added Prefix keywords, bug #665088 (diff)
downloadgentoo-a4cb36623d37346ba2539f66ae6cbb0ecb0c27f2.tar.gz
gentoo-a4cb36623d37346ba2539f66ae6cbb0ecb0c27f2.tar.bz2
gentoo-a4cb36623d37346ba2539f66ae6cbb0ecb0c27f2.zip
dev-libs/softhsm: version bump
Signed-off-by: Alon Bar-Lev <alonbl@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
Diffstat (limited to 'dev-libs/softhsm/softhsm-2.5.0.ebuild')
-rw-r--r--dev-libs/softhsm/softhsm-2.5.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-libs/softhsm/softhsm-2.5.0.ebuild b/dev-libs/softhsm/softhsm-2.5.0.ebuild
new file mode 100644
index 000000000000..aecd75f474e9
--- /dev/null
+++ b/dev-libs/softhsm/softhsm-2.5.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A software PKCS#11 implementation"
+HOMEPAGE="https://www.opendnssec.org/"
+SRC_URI="https://www.opendnssec.org/files/source/${P}.tar.gz"
+
+KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="bindist libressl migration-tool test"
+SLOT="2"
+LICENSE="BSD"
+
+RDEPEND="migration-tool? ( dev-db/sqlite:3= )
+ !libressl? ( dev-libs/openssl:=[bindist=] )
+ libressl? ( dev-libs/libressl:= )
+ !~dev-libs/softhsm-2.0.0:0"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ sys-devel/gcc:=[cxx]
+ test? ( dev-util/cppunit )"
+
+DOCS=(
+ NEWS
+ README.md
+)
+
+src_configure() {
+ econf \
+ --disable-static \
+ --with-crypto-backend=openssl \
+ --disable-p11-kit \
+ --localstatedir="${EROOT}/var" \
+ $(use_enable !bindist ecc) \
+ $(use_enable !libressl gost) \
+ $(use_with migration-tool migrate)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+
+ keepdir "${EROOT}/var/lib/softhsm/tokens"
+}