summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <davidroman96@gmail.com>2019-01-13 13:37:27 +0100
committerCraig Andrews <candrews@gentoo.org>2019-01-14 13:51:17 -0500
commit2e29bb29e57ff5256371265b0762a6d2256f2a7a (patch)
tree22288ec87ac43aed39c902283d403ac07630cd4c /dev-libs/spdlog
parentapp-admin/helm: Version bump to 2.12.2 (diff)
downloadgentoo-2e29bb29e57ff5256371265b0762a6d2256f2a7a.tar.gz
gentoo-2e29bb29e57ff5256371265b0762a6d2256f2a7a.tar.bz2
gentoo-2e29bb29e57ff5256371265b0762a6d2256f2a7a.zip
dev-libs/spdlog: verbump to 1.3.0
Closes: https://bugs.gentoo.org/675366 Package-Manager: Portage-2.3.55, Repoman-2.3.12 Signed-off-by: David Roman <davidroman96@gmail.com> Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-libs/spdlog')
-rw-r--r--dev-libs/spdlog/Manifest1
-rw-r--r--dev-libs/spdlog/spdlog-1.3.0.ebuild40
-rw-r--r--dev-libs/spdlog/spdlog-9999.ebuild7
3 files changed, 45 insertions, 3 deletions
diff --git a/dev-libs/spdlog/Manifest b/dev-libs/spdlog/Manifest
index 32fe47d178dc..f506ef1a56bc 100644
--- a/dev-libs/spdlog/Manifest
+++ b/dev-libs/spdlog/Manifest
@@ -1,3 +1,4 @@
DIST spdlog-1.0.0.tar.gz 183855 BLAKE2B 30d54fef03a83f968cfebacf95a484ff397126771a7ea022556aebd07e2f7694af35b278f75ee24372283ff1428e21247fd4329794d64a65bd6220a93f21db3c SHA512 4d3cbc1926be513256b5837a53fce425f6d352bb4ab262074f205450cd4eadc09feea9dc8d8c03b3f1e9792bcfbcff414be79e51d58234f540946428bbd88cd1
DIST spdlog-1.1.0.tar.gz 183937 BLAKE2B 51af49f641df69e78835bd6b9545da53c0e111bab60a5f0dbf4a1d0e70101309394ffea195176ea371f08b772c2be1c22c2da16006fc9699f47593cf82a6c0fd SHA512 65fbe6e9dffb25e814f72f2ef7982eed213fc16edfabb1377f865c94fd0488190e160dfea83ac06979a41f2fb2fa47a454989ebee0a2c5012bd404b977648439
DIST spdlog-1.2.1.tar.gz 188284 BLAKE2B c3491a9c44d8a94c51d50c9ef36a2105f77e8fb61bb7b2b81a341609f433abbe3a74e7b4a467dd715a5d906f976740716488d07b4510f366556ab59d160ceefe SHA512 418f91efc207fa227558212d82c41639c0bb59e84ea47447e0b6276c4842e97f1f8aaf5802c071ef15d80ec525e317e70b6a39661a6c96ab39d33d9bd1570da1
+DIST spdlog-1.3.0.tar.gz 202637 BLAKE2B 97027a3672b826e294dbdc202afa913a42ddae5a02a569ac28c41d79b96128de045ac5df30a76d888d6b3bea5093fb75b006365d7b1b296842750a39f43835d6 SHA512 019a52d4b6c66287ee2a6e8177457ecbbb78e1cb894f4a0a90b83a84d66cd37b397cdf77892d9116e4c34113bd3277d606d578bc96ec6521ae7745f08b1aa54f
diff --git a/dev-libs/spdlog/spdlog-1.3.0.ebuild b/dev-libs/spdlog/spdlog-1.3.0.ebuild
new file mode 100644
index 000000000000..497e7da9b419
--- /dev/null
+++ b/dev-libs/spdlog/spdlog-1.3.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="Very fast, header only, C++ logging library"
+HOMEPAGE="https://github.com/gabime/spdlog"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/gabime/spdlog"
+else
+ SRC_URI="https://github.com/gabime/spdlog/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0/1"
+IUSE="test"
+
+DEPEND="
+ >=dev-libs/libfmt-5.0.0
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-1.0.0-unbundle-fmt.patch" )
+
+src_configure() {
+ rm -r include/spdlog/fmt/bundled || die
+
+ local mycmakeargs=(
+ -DSPDLOG_BUILD_EXAMPLES=no
+ -DSPDLOG_BUILD_BENCH=no
+ -DSPDLOG_BUILD_TESTS=$(usex test)
+ )
+
+ cmake-utils_src_configure
+}
diff --git a/dev-libs/spdlog/spdlog-9999.ebuild b/dev-libs/spdlog/spdlog-9999.ebuild
index 03aaec9bd608..497e7da9b419 100644
--- a/dev-libs/spdlog/spdlog-9999.ebuild
+++ b/dev-libs/spdlog/spdlog-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit cmake-utils
@@ -32,7 +32,8 @@ src_configure() {
local mycmakeargs=(
-DSPDLOG_BUILD_EXAMPLES=no
- -DSPDLOG_BUILD_TESTING=$(usex test)
+ -DSPDLOG_BUILD_BENCH=no
+ -DSPDLOG_BUILD_TESTS=$(usex test)
)
cmake-utils_src_configure