summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <davidroman96@gmail.com>2020-01-20 22:08:54 +0100
committerCraig Andrews <candrews@gentoo.org>2020-01-20 21:12:34 -0500
commitcb4209494b05520fa84511c0ec3df825085af73e (patch)
tree98f46ce262b3a5de1678ae2cffe16699351a15c8 /dev-libs/spdlog
parentsci-libs/m4ri: various upstreamed patches (diff)
downloadgentoo-cb4209494b05520fa84511c0ec3df825085af73e.tar.gz
gentoo-cb4209494b05520fa84511c0ec3df825085af73e.tar.bz2
gentoo-cb4209494b05520fa84511c0ec3df825085af73e.zip
dev-libs/spdlog: bump to 1.5.0
Closes: https://bugs.gentoo.org/696710 Closes: https://bugs.gentoo.org/699346 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: David Roman <davidroman96@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/14113 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-libs/spdlog')
-rw-r--r--dev-libs/spdlog/Manifest1
-rw-r--r--dev-libs/spdlog/files/spdlog-9999-unbundle-fmt.patch45
-rw-r--r--dev-libs/spdlog/spdlog-1.5.0.ebuild47
-rw-r--r--dev-libs/spdlog/spdlog-9999.ebuild20
4 files changed, 61 insertions, 52 deletions
diff --git a/dev-libs/spdlog/Manifest b/dev-libs/spdlog/Manifest
index 9beed729a3b6..9c5db7b8547b 100644
--- a/dev-libs/spdlog/Manifest
+++ b/dev-libs/spdlog/Manifest
@@ -1,3 +1,4 @@
DIST spdlog-1.2.1.tar.gz 188284 BLAKE2B c3491a9c44d8a94c51d50c9ef36a2105f77e8fb61bb7b2b81a341609f433abbe3a74e7b4a467dd715a5d906f976740716488d07b4510f366556ab59d160ceefe SHA512 418f91efc207fa227558212d82c41639c0bb59e84ea47447e0b6276c4842e97f1f8aaf5802c071ef15d80ec525e317e70b6a39661a6c96ab39d33d9bd1570da1
DIST spdlog-1.3.0.tar.gz 202637 BLAKE2B 97027a3672b826e294dbdc202afa913a42ddae5a02a569ac28c41d79b96128de045ac5df30a76d888d6b3bea5093fb75b006365d7b1b296842750a39f43835d6 SHA512 019a52d4b6c66287ee2a6e8177457ecbbb78e1cb894f4a0a90b83a84d66cd37b397cdf77892d9116e4c34113bd3277d606d578bc96ec6521ae7745f08b1aa54f
DIST spdlog-1.3.1.tar.gz 202634 BLAKE2B 2465a8d1a38af1527ae66d92f5dd91ad504d01e44ac47702e315f7448e19f01743627357132f0561e48807315df9b102f337f95cab5a7aae3ec0ae7ceff940b9 SHA512 a851a44b6384f493dd312ae0a611d068af46bbfe8daf1c2f61f13d8836a3801f41b339074fbe8da8e428131c82fa5c4a9e3320a55cbdd4b7aff8bb349dfff7dd
+DIST spdlog-1.5.0.tar.gz 270416 BLAKE2B bac6c6650f8347458dd2dd66f318b43a769b0896d68f6a6f1310754527a69feaa52b2f6f48d67c7e811c2dafa5d3863a9a07c738df8c12abed2718fb06254b28 SHA512 78991c943dd95af563c4b29545b9b5d635caf1af5031262dde734ecf70c0b4ae866d954ee77b050f9f0cc089a3bc57ee9583895e51cb00dd1cc6c10ff905ca34
diff --git a/dev-libs/spdlog/files/spdlog-9999-unbundle-fmt.patch b/dev-libs/spdlog/files/spdlog-9999-unbundle-fmt.patch
deleted file mode 100644
index f6f37b5e493c..000000000000
--- a/dev-libs/spdlog/files/spdlog-9999-unbundle-fmt.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-diff --git a/include/spdlog/fmt/fmt.h b/include/spdlog/fmt/fmt.h
-index 5d039b8c..8107b19a 100644
---- a/include/spdlog/fmt/fmt.h
-+++ b/include/spdlog/fmt/fmt.h
-@@ -19,9 +19,6 @@
- #ifndef FMT_USE_WINDOWS_H
- #define FMT_USE_WINDOWS_H 0
- #endif
--#include "bundled/core.h"
--#include "bundled/format.h"
--#else // SPDLOG_FMT_EXTERNAL is defined - use external fmtlib
--#include "fmt/core.h"
--#include "fmt/format.h"
--#endif
-+#endif // SPDLOG_FMT_EXTERNAL is defined - use external fmtlib
-+#include <fmt/core.h>
-+#include <fmt/format.h>
-diff --git a/include/spdlog/fmt/ostr.h b/include/spdlog/fmt/ostr.h
-index 9902898f..5e92a592 100644
---- a/include/spdlog/fmt/ostr.h
-+++ b/include/spdlog/fmt/ostr.h
-@@ -11,8 +11,6 @@
- #ifndef FMT_HEADER_ONLY
- #define FMT_HEADER_ONLY
- #endif
--#include "bundled/ostream.h"
--#include "fmt.h"
--#else
--#include <fmt/ostream.h>
- #endif
-+
-+#include <fmt/ostream.h>
-diff --git a/src/spdlog.cpp b/src/spdlog.cpp
-index be91412d..d68dd522 100644
---- a/src/spdlog.cpp
-+++ b/src/spdlog.cpp
-@@ -104,7 +104,7 @@ template std::shared_ptr<spdlog::logger> spdlog::stderr_logger_st<spdlog::async_
- // All rights reserved.
-
- #if !defined(SPDLOG_FMT_EXTERNAL)
--#include "spdlog/fmt/bundled/format-inl.h"
-+#include <fmt/format-inl.h>
-
- FMT_BEGIN_NAMESPACE
- template struct internal::basic_data<void>;
diff --git a/dev-libs/spdlog/spdlog-1.5.0.ebuild b/dev-libs/spdlog/spdlog-1.5.0.ebuild
new file mode 100644
index 000000000000..060e167a8afd
--- /dev/null
+++ b/dev-libs/spdlog/spdlog-1.5.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Very fast, header only, C++ logging library"
+HOMEPAGE="https://github.com/gabime/spdlog"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/gabime/${PN}"
+else
+ SRC_URI="https://github.com/gabime/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0/1"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+DEPEND="
+ >=dev-libs/libfmt-5.3.0:=
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ cmake_src_prepare
+ rm -r include/spdlog/fmt/bundled || die "Failed to delete bundled libfmt"
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DSPDLOG_BUILD_BENCH=no
+ -DSPDLOG_BUILD_EXAMPLE=no
+ -DSPDLOG_FMT_EXTERNAL=yes
+ -DSPDLOG_BUILD_SHARED=no
+ -DSPDLOG_BUILD_TESTS=$(usex test)
+ )
+
+ cmake_src_configure
+}
diff --git a/dev-libs/spdlog/spdlog-9999.ebuild b/dev-libs/spdlog/spdlog-9999.ebuild
index f0b80109ac4a..060e167a8afd 100644
--- a/dev-libs/spdlog/spdlog-9999.ebuild
+++ b/dev-libs/spdlog/spdlog-9999.ebuild
@@ -10,9 +10,9 @@ HOMEPAGE="https://github.com/gabime/spdlog"
if [[ ${PV} == *9999 ]]; then
inherit git-r3
- EGIT_REPO_URI="https://github.com/gabime/spdlog"
+ EGIT_REPO_URI="https://github.com/gabime/${PN}"
else
- SRC_URI="https://github.com/gabime/spdlog/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/gabime/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
fi
@@ -21,19 +21,25 @@ SLOT="0/1"
IUSE="test"
RESTRICT="!test? ( test )"
+BDEPEND="
+ virtual/pkgconfig
+"
DEPEND="
- >=dev-libs/libfmt-5.0.0
+ >=dev-libs/libfmt-5.3.0:=
"
RDEPEND="${DEPEND}"
-PATCHES=( "${FILESDIR}/${PN}-9999-unbundle-fmt.patch" )
+src_prepare() {
+ cmake_src_prepare
+ rm -r include/spdlog/fmt/bundled || die "Failed to delete bundled libfmt"
+}
src_configure() {
- rm -r include/spdlog/fmt/bundled || die
-
local mycmakeargs=(
- -DSPDLOG_BUILD_EXAMPLE=no
-DSPDLOG_BUILD_BENCH=no
+ -DSPDLOG_BUILD_EXAMPLE=no
+ -DSPDLOG_FMT_EXTERNAL=yes
+ -DSPDLOG_BUILD_SHARED=no
-DSPDLOG_BUILD_TESTS=$(usex test)
)