summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-02 05:53:14 +0100
committerSam James <sam@gentoo.org>2021-04-03 16:54:35 +0100
commit804fdd99eb85e39b9a97651f12f64102f074ab29 (patch)
treee06e9f9da3f593a0e3c3e6b1a392a57fc8777ae8 /dev-libs/squareball
parentdev-libs/simdjson: drop unused toolchain-funcs (diff)
downloadgentoo-804fdd99eb85e39b9a97651f12f64102f074ab29.tar.gz
gentoo-804fdd99eb85e39b9a97651f12f64102f074ab29.tar.bz2
gentoo-804fdd99eb85e39b9a97651f12f64102f074ab29.zip
dev-libs/squareball: EAPI 7, eutils--, ltprune--
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/squareball')
-rw-r--r--dev-libs/squareball/squareball-0.2.0.ebuild27
-rw-r--r--dev-libs/squareball/squareball-9999.ebuild27
2 files changed, 20 insertions, 34 deletions
diff --git a/dev-libs/squareball/squareball-0.2.0.ebuild b/dev-libs/squareball/squareball-0.2.0.ebuild
index aeb29384561f..f66cb329826c 100644
--- a/dev-libs/squareball/squareball-0.2.0.ebuild
+++ b/dev-libs/squareball/squareball-0.2.0.ebuild
@@ -1,22 +1,17 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
if [[ ${PV} = *9999* ]]; then
EGIT_REPO_URI="https://github.com/rafaelmartins/${PN}.git"
- inherit git-r3 autotools
+ inherit autotools git-r3
fi
-inherit eutils ltprune
-
DESCRIPTION="A general-purpose library for C99"
HOMEPAGE="https://github.com/rafaelmartins/squareball"
-
-SRC_URI="https://github.com/rafaelmartins/${PN}/releases/download/v${PV}/${P}.tar.xz"
-if [[ ${PV} = *9999* ]]; then
- SRC_URI=""
-else
+if ! [[ ${PV} = *9999* ]]; then
+ SRC_URI="https://github.com/rafaelmartins/${PN}/releases/download/v${PV}/${P}.tar.xz"
KEYWORDS="~amd64 ~x86"
fi
@@ -25,14 +20,11 @@ SLOT="0"
IUSE="doc test static-libs"
RESTRICT="!test? ( test )"
-RDEPEND=""
-
-DEPEND="
+BDEPEND="
virtual/pkgconfig
- test? (
- dev-util/cmocka )
- doc? (
- app-doc/doxygen )"
+ doc? ( app-doc/doxygen )
+"
+DEPEND="test? ( dev-util/cmocka )"
src_prepare() {
[[ ${PV} = *9999* ]] && eautoreconf
@@ -55,5 +47,6 @@ src_compile() {
src_install() {
use doc && HTML_DOCS=( doc/build/html/* )
default
- prune_libtool_files --all
+
+ find "${ED}" -name '*.la' -delete || die
}
diff --git a/dev-libs/squareball/squareball-9999.ebuild b/dev-libs/squareball/squareball-9999.ebuild
index aeb29384561f..28dcbab67e2f 100644
--- a/dev-libs/squareball/squareball-9999.ebuild
+++ b/dev-libs/squareball/squareball-9999.ebuild
@@ -1,22 +1,17 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
if [[ ${PV} = *9999* ]]; then
EGIT_REPO_URI="https://github.com/rafaelmartins/${PN}.git"
- inherit git-r3 autotools
+ inherit autotools git-r3
fi
-inherit eutils ltprune
-
DESCRIPTION="A general-purpose library for C99"
HOMEPAGE="https://github.com/rafaelmartins/squareball"
-
-SRC_URI="https://github.com/rafaelmartins/${PN}/releases/download/v${PV}/${P}.tar.xz"
-if [[ ${PV} = *9999* ]]; then
- SRC_URI=""
-else
+if [[ ${PV} != *9999* ]]; then
+ SRC_URI="https://github.com/rafaelmartins/${PN}/releases/download/v${PV}/${P}.tar.xz"
KEYWORDS="~amd64 ~x86"
fi
@@ -25,14 +20,11 @@ SLOT="0"
IUSE="doc test static-libs"
RESTRICT="!test? ( test )"
-RDEPEND=""
-
-DEPEND="
+BDEPEND="
virtual/pkgconfig
- test? (
- dev-util/cmocka )
- doc? (
- app-doc/doxygen )"
+ doc? ( app-doc/doxygen )
+"
+DEPEND="test? ( dev-util/cmocka )"
src_prepare() {
[[ ${PV} = *9999* ]] && eautoreconf
@@ -55,5 +47,6 @@ src_compile() {
src_install() {
use doc && HTML_DOCS=( doc/build/html/* )
default
- prune_libtool_files --all
+
+ find "${ED}" -name '*.la' -delete || die
}