summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/svrcore
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/svrcore')
-rw-r--r--dev-libs/svrcore/Manifest1
-rw-r--r--dev-libs/svrcore/files/svrcore-4.0.4-gentoo.patch100
-rw-r--r--dev-libs/svrcore/metadata.xml7
-rw-r--r--dev-libs/svrcore/svrcore-4.0.4.ebuild41
4 files changed, 149 insertions, 0 deletions
diff --git a/dev-libs/svrcore/Manifest b/dev-libs/svrcore/Manifest
new file mode 100644
index 000000000000..7cbebeda0bfe
--- /dev/null
+++ b/dev-libs/svrcore/Manifest
@@ -0,0 +1 @@
+DIST svrcore-4.0.4.tar.bz2 217076 SHA256 4772fb4705492de11f10d3e020f0ceca2541415c009ae5444988d6becca36a58 SHA512 4a63e2618ef8f508e71adf212eefae56e3c9d9898b924f405399bb99793de57bd178a3417f9e837c474e7960b6eb8a3cbe775b420c8fecbd974e89b4196b78fc WHIRLPOOL 0bf45637685cb03753cd68840381cd5c906e01a61f813156e756e99fa97e7c6d61bc96b4c1f18aa016acf45d54d6288f733c39bf259c241416c1efc89cb0fc93
diff --git a/dev-libs/svrcore/files/svrcore-4.0.4-gentoo.patch b/dev-libs/svrcore/files/svrcore-4.0.4-gentoo.patch
new file mode 100644
index 000000000000..83e9f7fca359
--- /dev/null
+++ b/dev-libs/svrcore/files/svrcore-4.0.4-gentoo.patch
@@ -0,0 +1,100 @@
+diff -uNr src/Makefile.am svrcore-4.0.4src/Makefile.am
+--- src/Makefile.am 2006-12-14 18:07:32.000000000 +0100
++++ src/Makefile.am 2007-08-06 17:37:17.000000000 +0200
+@@ -4,8 +4,8 @@
+ Makefile.win \
+ ntgetpin.rc
+
+-lib_LTLIBRARIES = libsvrcore.la
+-include_HEADERS = svrcore.h
++pkglib_LTLIBRARIES = libsvrcore.la
++pkginclude_HEADERS = svrcore.h
+ libsvrcore_la_SOURCES = alt.c \
+ cache.c \
+ errors.c \
+diff -uNr svrcore.pc.in svrcore.pc.in
+--- svrcore.pc.in 2006-12-14 18:07:32.000000000 +0100
++++ svrcore.pc.in 2007-08-06 17:38:12.000000000 +0200
+@@ -1,11 +1,11 @@
+ prefix=@prefix@
+ exec_prefix=@exec_prefix@
+-libdir=@libdir@
+-includedir=@includedir@
++libdir=@libdir@/@PACKAGE@
++includedir=@includedir@/@PACKAGE@
+
+ Name: svrcore
+ Description: Svrcore - Secure PIN handling using NSS crypto
+ Version: @VERSION@
+ Requires: @NSPR_NAME@ >= @NSPR_MIN_VER@ , @NSS_NAME@ >= @NSS_MIN_VER@
+-Libs: -lsvrcore
++Libs: -L${libdir} -lsvrcore
+ Cflags: -I${includedir}
+diff -ur m4.orig/nspr.m4 m4/nspr.m4
+--- m4.orig/nspr.m4 2009-10-06 01:40:18.979484804 +0300
++++ m4/nspr.m4 2009-10-06 01:41:21.539982482 +0300
+@@ -52,28 +52,6 @@
+ ],
+ AC_MSG_RESULT(no))
+
+-# see if we are doing an "in-tree" build with the other
+-# mozilla components
+-if test -z "$nspr_inc" -o -z "$nspr_lib" ; then
+- for nsprpath in "../../dist" "../../dist/*.OBJ" ; do
+- savedir=`pwd`
+- cd $nsprpath
+- abs_nsprpath=`pwd`
+- cd $savedir
+- if test -f "$abs_nsprpath/include/nspr/nspr.h" ; then
+- nspr_inc="-I$abs_nsprpath/include/nspr"
+- elif test -f "$abs_nsprpath/include/nspr.h" ; then
+- nspr_inc="-I$abs_nsprpath/include"
+- fi
+- if test -d "$abs_nsprpath/lib" ; then
+- nspr_lib="-L$abs_nsprpath/lib"
+- fi
+- if test -n "$nspr_inc" -a -n "$nspr_lib" ; then
+- break
+- fi
+- done
+-fi
+-
+ # if NSPR is not found yet, try pkg-config
+ # last resort
+ if test -z "$nspr_inc" -o -z "$nspr_lib" ; then
+diff -ur m4.orig/nss.m4 m4/nss.m4
+--- m4.orig/nss.m4 2009-10-06 01:40:18.979484804 +0300
++++ m4/nss.m4 2009-10-06 01:41:31.291485717 +0300
+@@ -52,32 +52,6 @@
+ ],
+ AC_MSG_RESULT(no))
+
+-# see if we are building "in tree" with the
+-# other mozilla components
+-if test -z "$nss_inc" -o -z "$nss_lib"; then
+- nsslibpath=`echo ../../dist/*.OBJ/lib | cut -f1 -d' '`
+- savedir=`pwd`
+- cd $nsslibpath
+- abs_nsslibpath=`pwd`
+- cd $savedir
+- nssincpath=../../dist/public/nss
+- savedir=`pwd`
+- cd $nssincpath
+- abs_nssincpath=`pwd`
+- cd $savedir
+- if test -f "$abs_nssincpath/nss.h" ; then
+- nss_inc="-I$abs_nssincpath"
+- fi
+- if test -d "$abs_nsslibpath" ; then
+- nss_lib="-L$abs_nsslibpath"
+- fi
+- if test -n "$nss_inc" -a -n "$nss_lib" ; then
+- AC_MSG_CHECKING(using in-tree NSS from $nssincpath $nsslibpath)
+- else
+- AC_MSG_CHECKING(could not find in-tree NSS in ../../dist)
+- fi
+-fi
+-
+ # if NSS is not found yet, try pkg-config
+ # last resort
+ if test -z "$nss_inc" -o -z "$nss_lib"; then
diff --git a/dev-libs/svrcore/metadata.xml b/dev-libs/svrcore/metadata.xml
new file mode 100644
index 000000000000..2fbcb323ebf0
--- /dev/null
+++ b/dev-libs/svrcore/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>lxnay@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-libs/svrcore/svrcore-4.0.4.ebuild b/dev-libs/svrcore/svrcore-4.0.4.ebuild
new file mode 100644
index 000000000000..fa3e5cc310ab
--- /dev/null
+++ b/dev-libs/svrcore/svrcore-4.0.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit multilib autotools eutils
+
+DESCRIPTION="Mozilla LDAP C SDK"
+HOMEPAGE="http://wiki.mozilla.org/LDAP_C_SDK"
+SRC_URI="http://ftp.mozilla.org/pub/mozilla.org/directory/svrcore/releases/"${PV}"/src/"${P}".tar.bz2"
+
+LICENSE="MPL-1.1 GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=">=dev-libs/nss-3.11
+ >=dev-libs/nspr-4.6"
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/"${P}"-gentoo.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf --with-pic || die "cannot configure"
+}
+
+src_install () {
+ einstall || die "emake failed"
+
+ # cope with libraries being in /usr/lib/svrcore
+ echo "LDPATH=/usr/$(get_libdir)/svrcore" > 08svrcore
+ dodir /etc/env.d
+ doenvd 08svrcore
+
+ dodoc ChangeLog INSTALL NEWS TODO README AUTHORS
+}