summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-05-18 23:11:59 +0000
committerSam James <sam@gentoo.org>2021-05-18 23:13:29 +0000
commitdab0c933c1c8cb795ccc0b406c49bbf6f2f45f1a (patch)
tree46b7e1cab7bd8918b554dbcc830a7334dc361f55 /dev-libs/tinyxml2
parentdev-perl/Pod-LaTeX: Remove old (diff)
downloadgentoo-dab0c933c1c8cb795ccc0b406c49bbf6f2f45f1a.tar.gz
gentoo-dab0c933c1c8cb795ccc0b406c49bbf6f2f45f1a.tar.bz2
gentoo-dab0c933c1c8cb795ccc0b406c49bbf6f2f45f1a.zip
dev-libs/tinyxml2: add 8.1.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/tinyxml2')
-rw-r--r--dev-libs/tinyxml2/Manifest1
-rw-r--r--dev-libs/tinyxml2/files/tinyxml2-8.1.0-meson-typo.patch17
-rw-r--r--dev-libs/tinyxml2/tinyxml2-8.1.0.ebuild44
3 files changed, 62 insertions, 0 deletions
diff --git a/dev-libs/tinyxml2/Manifest b/dev-libs/tinyxml2/Manifest
index 98d44932bd89..0b8ab041f853 100644
--- a/dev-libs/tinyxml2/Manifest
+++ b/dev-libs/tinyxml2/Manifest
@@ -1,2 +1,3 @@
DIST tinyxml2-7.1.0.tar.gz 592717 BLAKE2B 5936356d472b8642bebb9f02579e6beda14446d57749f1e7a869ff941a03a5ad30624c4db4b2eaaaca48d7f339e3100fddfd58f96bbcfc22737a23d9c9198c9a SHA512 09d5f37018f79a593ff35e33d4296c9ec643a22e83c0cee4c37949300f86201eee07e9b7e6ba55044d8abb438d5d21b70d5843a96ae4652389bb164047ec31e1
DIST tinyxml2-8.0.0.tar.gz 593833 BLAKE2B afc21220e28a1c139b1abd89e67f8e64980d2ba9bc6f60a33d435a4a02cb40ecacc27ac28bd9702ac3a435f66764ebb752b597a1b1e178d0b549e366d5b669dd SHA512 bcbb065c2af34ea681ec556377fd22e720b6f5d4caa73f432b1e34e08603a96f2233763f0ec5ae86b9ee71ddbe3062f58d3794cd3a162ce6903435530de0bba6
+DIST tinyxml2-8.1.0.tar.gz 619733 BLAKE2B 7a7e1a250bc8944614ecf578183b41340e7519ad2181e8023244d82e83d9a85fc600e5f00051b7f6f8ebda760a1ac11cb8bfe381fc9f6432f315aa6fdb310a83 SHA512 1ef50ee2648d423f38b6ebb3e45ec3798b87cf73a75aa0e49ae697a2006517d05c8298b325de70ee2aa706546235860f01541ff753c8a1bd97fa862a4ebb5c09
diff --git a/dev-libs/tinyxml2/files/tinyxml2-8.1.0-meson-typo.patch b/dev-libs/tinyxml2/files/tinyxml2-8.1.0-meson-typo.patch
new file mode 100644
index 000000000000..b13b27af7928
--- /dev/null
+++ b/dev-libs/tinyxml2/files/tinyxml2-8.1.0-meson-typo.patch
@@ -0,0 +1,17 @@
+https://github.com/leethomason/tinyxml2/commit/0838dd11a3d7a122799298d6556cff501b88421a.patch
+
+From 0838dd11a3d7a122799298d6556cff501b88421a Mon Sep 17 00:00:00 2001
+From: heitbaum <rudi@heitbaum.com>
+Date: Mon, 17 May 2021 15:14:01 +1000
+Subject: [PATCH] meson.build: fix typo
+--- a/meson.build
++++ b/meson.build
+@@ -58,7 +58,7 @@ dep_tinyxml2 = declare_dependency(
+ # This is the new way to set dependencies, but let's not break users of older
+ # versions of meson
+ if meson.version().version_compare('>= 0.54.0')
+- meson.override_dependency('tinyxml2', dep_tinxyml2)
++ meson.override_dependency('tinyxml2', dep_tinyxml2)
+ endif
+
+ if get_option('tests')
diff --git a/dev-libs/tinyxml2/tinyxml2-8.1.0.ebuild b/dev-libs/tinyxml2/tinyxml2-8.1.0.ebuild
new file mode 100644
index 000000000000..1ceb8e57aecf
--- /dev/null
+++ b/dev-libs/tinyxml2/tinyxml2-8.1.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson multilib-minimal
+
+DESCRIPTION="A simple, small, efficient, C++ XML parser"
+HOMEPAGE="http://www.grinninglizard.com/tinyxml2/ https://github.com/leethomason/tinyxml2/"
+SRC_URI="https://github.com/leethomason/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0/8"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-meson-typo.patch
+)
+
+multilib_src_configure() {
+ local mymesonargs=()
+
+ if multilib_is_native_abi ; then
+ mymesonargs+=(
+ $(meson_use test tests)
+ )
+ fi
+
+ meson_src_configure "${mymesonargs[@]}"
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_test() {
+ meson_src_test
+}
+
+multilib_src_install() {
+ meson_src_install
+}