summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/ucommon/files/ucommon-6.3.1-gcrypt_autotools.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/ucommon/files/ucommon-6.3.1-gcrypt_autotools.patch')
-rw-r--r--dev-libs/ucommon/files/ucommon-6.3.1-gcrypt_autotools.patch48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-libs/ucommon/files/ucommon-6.3.1-gcrypt_autotools.patch b/dev-libs/ucommon/files/ucommon-6.3.1-gcrypt_autotools.patch
new file mode 100644
index 000000000000..fb04130a0a85
--- /dev/null
+++ b/dev-libs/ucommon/files/ucommon-6.3.1-gcrypt_autotools.patch
@@ -0,0 +1,48 @@
+--- ucommon-6.3.1/configure.ac
++++ ucommon-6.3.1/configure.ac
+@@ -38,8 +38,12 @@
+ OPENSSL_LINK=""
+ MODULE_FLAGS="-module -shared -avoid-version"
+
++AM_SILENT_RULES([yes])
++
+ CHECKFLAGS="$CHECKFLAGS"
+
++m4_include([m4/libgcrypt.m4])
++
+ case "$with_crypto" in
+ ssl|openssl)
+ ssl="openssl"
+@@ -598,7 +602,8 @@
+ ;;
+ gnutls|gnu)
+ if test ! -z "$GNUTLS_LIBS" ; then
+- SECURE_LIBS="$GNUTLS_LIBS"
++ AM_PATH_LIBGCRYPT
++ SECURE_LIBS="$GNUTLS_LIBS $LIBGCRYPT_LIBS"
+ SECURE="gnutls"
+ fi
+ ;;
+--- ucommon-6.3.1/utils/Makefile.am
++++ ucommon-6.3.1/utils/Makefile.am
+@@ -10,9 +10,9 @@
+ # implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
+
+ MAINTAINERCLEANFILES = Makefile.in Makefile
+-AM_CXXFLAGS = -I$(top_srcdir)/inc @UCOMMON_FLAGS@
++AM_CXXFLAGS = -I$(top_srcdir)/inc @UCOMMON_FLAGS@ @LIBGCRYPT_CFLAGS@
+ AM_CPPFLAGS = -I$(top_srcdir)/inc
+-LDADD = ../corelib/libucommon.la @UCOMMON_LIBS@
++LDADD = ../corelib/libucommon.la @UCOMMON_LIBS@ @LIBGCRYPT_LIBS@
+ EXTRA_DIST = *.1 CMakeLists.txt
+
+ man_MANS = args.1 scrub-files.1 mdsum.1 zerofill.1 car.1 sockaddr.1 \
+@@ -21,7 +21,7 @@
+
+ noinst_PROGRAMS = demoSSL
+ demoSSL_SOURCES = ssl.cpp
+-demoSSL_LDFLAGS = @SECURE_LOCAL@
++demoSSL_LDFLAGS = @SECURE_LOCAL@ @LIBGCRYPT_LIBS@
+
+ args_SOURCES = args.cpp
+