summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2015-08-18 14:55:59 +0200
committerLars Wendler <polynomial-c@gentoo.org>2015-08-18 14:55:59 +0200
commit8f44794b5ecfc9a34ac709d8a2a253260dedb410 (patch)
tree03cca983c0bd8812f8ca743aa7cbf76f61cf0db5 /dev-libs/ucommon/ucommon-6.5.2.ebuild
parentmedia-libs/opencv: contrib useflag added bug #557870. (diff)
downloadgentoo-8f44794b5ecfc9a34ac709d8a2a253260dedb410.tar.gz
gentoo-8f44794b5ecfc9a34ac709d8a2a253260dedb410.tar.bz2
gentoo-8f44794b5ecfc9a34ac709d8a2a253260dedb410.zip
dev-libs/ucommon: Version bump.
Package-Manager: portage-2.2.20.1 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-libs/ucommon/ucommon-6.5.2.ebuild')
-rw-r--r--dev-libs/ucommon/ucommon-6.5.2.ebuild81
1 files changed, 81 insertions, 0 deletions
diff --git a/dev-libs/ucommon/ucommon-6.5.2.ebuild b/dev-libs/ucommon/ucommon-6.5.2.ebuild
new file mode 100644
index 000000000000..f84d38e16327
--- /dev/null
+++ b/dev-libs/ucommon/ucommon-6.5.2.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+AUTOTOOLS_AUTORECONF=1
+
+inherit autotools-utils eutils
+
+DESCRIPTION="Portable C++ runtime for threads and sockets"
+HOMEPAGE="http://www.gnu.org/software/commoncpp"
+SRC_URI="mirror://gnu/commoncpp/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0/6"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux"
+IUSE="doc static-libs socks +cxx debug ssl gnutls"
+
+RDEPEND="
+ ssl? (
+ !gnutls? ( dev-libs/openssl:0= )
+ gnutls? (
+ net-libs/gnutls:0=
+ dev-libs/libgcrypt:0=
+ )
+ )"
+
+DEPEND="virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ ${RDEPEND}"
+
+DOCS=(README NEWS SUPPORT ChangeLog AUTHORS)
+PATCHES=(
+ "${FILESDIR}/6.1/install_gcrypt.m4_file.patch"
+ "${FILESDIR}/${PN}-6.3.1-gcrypt_autotools.patch"
+)
+
+# Needed for doxygen, bug #526726
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_prepare() {
+ # Aclocal 1.13 deprecated error BGO #467674
+ sed -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' -i configure.ac || die
+
+ # don't install latex and rtf documents
+ sed -e '/^GENERATE_LATEX/s@YES@NO@' -e '/^GENERATE_RTF/s@YES@NO@' \
+ -i Doxyfile.in || die
+
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myconf=""
+ if use ssl; then
+ myconf+=" --with-sslstack=$(usex gnutls gnu ssl) "
+ else
+ myconf+=" --with-sslstack=nossl ";
+ fi
+
+ local myeconfargs=(
+ $(use_enable socks)
+ $(use_enable cxx stdcpp)
+ ${myconf}
+ --enable-atomics
+ --with-pkg-config
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ use doc && autotools-utils_src_compile doxy
+}
+
+src_install() {
+ autotools-utils_src_install
+ if use doc; then
+ dohtml doc/html/*
+ fi
+}