summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2018-10-19 12:00:34 +0200
committerGuilherme Amadio <amadio@gentoo.org>2018-11-15 14:54:41 +0100
commite37803862bd22eeb3450af36d567d8626f8e4e11 (patch)
treede9500a405b978ef6be8df80c9e79a2651ba1fd2 /dev-libs/vc/vc-0.7.4.ebuild
parentsys-cluster/keepalived: fix crash during shutdown (diff)
downloadgentoo-e37803862bd22eeb3450af36d567d8626f8e4e11.tar.gz
gentoo-e37803862bd22eeb3450af36d567d8626f8e4e11.tar.bz2
gentoo-e37803862bd22eeb3450af36d567d8626f8e4e11.zip
dev-libs/vc: drop old versions
Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'dev-libs/vc/vc-0.7.4.ebuild')
-rw-r--r--dev-libs/vc/vc-0.7.4.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-libs/vc/vc-0.7.4.ebuild b/dev-libs/vc/vc-0.7.4.ebuild
deleted file mode 100644
index 280443a17a02..000000000000
--- a/dev-libs/vc/vc-0.7.4.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit cmake-utils
-
-DESCRIPTION="SIMD Vector Class Library for C++"
-HOMEPAGE="https://github.com/VcDevel/Vc"
-
-VC_TEST_DATA=( reference-{acos,asin,atan,ln,log2,log10,sincos}-{dp,sp}.dat )
-for i in ${VC_TEST_DATA[@]}; do
- SRC_URI+="test? ( http://compeng.uni-frankfurt.de/~kretz/Vc-testdata/$i -> ${P}-${i} ) "
-done
-
-SRC_URI+="https://github.com/VcDevel/Vc/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-src_unpack() {
- default_src_unpack
- S="${WORKDIR}"/Vc-${PV}
- if use test ; then
- mkdir -p "${WORKDIR}"/${P}_build/tests || die
- for i in ${VC_TEST_DATA[@]}; do
- cp "${DISTDIR}"/${P}-$i "${WORKDIR}"/${P}_build/tests/${i} || die
- done
- fi
-}
-
-src_configure() {
- local mycmakeargs=(
- $(cmake-utils_use_build test)
- )
- cmake-utils_src_configure
-}