summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2019-09-08 09:53:43 +0300
committerJoonas Niilola <juippis@gentoo.org>2019-09-08 09:53:43 +0300
commit80c683651f56c82bb3a1fe607a7b475657fa22a7 (patch)
treed215d9875315ae2f8b472d7ef80588db6ae0a0d2 /dev-libs/voikko-fi/voikko-fi-2.3.ebuild
parentdev-libs/libvoikko: new package (diff)
downloadgentoo-80c683651f56c82bb3a1fe607a7b475657fa22a7.tar.gz
gentoo-80c683651f56c82bb3a1fe607a7b475657fa22a7.tar.bz2
gentoo-80c683651f56c82bb3a1fe607a7b475657fa22a7.zip
dev-libs/voikko-fi: new package
- Finnish dictionary for libvoikko based spell checkers (vvfst format), dependency of libreoffice-voikko Package-Manager: Portage-2.3.75, Repoman-2.3.17 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs/voikko-fi/voikko-fi-2.3.ebuild')
-rw-r--r--dev-libs/voikko-fi/voikko-fi-2.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-libs/voikko-fi/voikko-fi-2.3.ebuild b/dev-libs/voikko-fi/voikko-fi-2.3.ebuild
new file mode 100644
index 000000000000..c9b591d3d0a6
--- /dev/null
+++ b/dev-libs/voikko-fi/voikko-fi-2.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5..7} )
+
+inherit python-any-r1
+
+DESCRIPTION="Finnish dictionary for libvoikko based spell checkers (vvfst format)"
+HOMEPAGE="https://voikko.puimula.org/"
+SRC_URI="https://www.puimula.org/voikko-sources/${PN}/${P}.tar.gz"
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="${PYTHON_DEPS}
+ dev-libs/foma
+ $(python_gen_any_dep '
+ >=dev-libs/libvoikko-4.0[${PYTHON_USEDEP}]
+ ')"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake vvfst
+}
+
+src_install() {
+ emake DESTDIR="${D}/usr/share/voikko/" vvfst-install
+ einstalldocs
+}