summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-05-22 16:06:16 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-05-22 16:32:20 +0200
commit44c7a0aeeb04069988c58819172da3f53d74fd82 (patch)
treee02db83e587a97d5f9b943955489885792ce9e3e /dev-libs/volume_key
parentdev-libs/libbsd: Bump to version 0.9.0 (diff)
downloadgentoo-44c7a0aeeb04069988c58819172da3f53d74fd82.tar.gz
gentoo-44c7a0aeeb04069988c58819172da3f53d74fd82.tar.bz2
gentoo-44c7a0aeeb04069988c58819172da3f53d74fd82.zip
dev-libs/volume_key: Bump to version 0.3.10
Package-Manager: Portage-2.3.38, Repoman-2.3.9
Diffstat (limited to 'dev-libs/volume_key')
-rw-r--r--dev-libs/volume_key/Manifest1
-rw-r--r--dev-libs/volume_key/files/volume_key-0.3.10-find_python.patch55
-rw-r--r--dev-libs/volume_key/volume_key-0.3.10.ebuild48
3 files changed, 104 insertions, 0 deletions
diff --git a/dev-libs/volume_key/Manifest b/dev-libs/volume_key/Manifest
index 2705259edcdc..e57c1b261fb9 100644
--- a/dev-libs/volume_key/Manifest
+++ b/dev-libs/volume_key/Manifest
@@ -1 +1,2 @@
+DIST volume_key-0.3.10.tar.xz 474720 BLAKE2B 726252263976b63c3e73dc42bd0166aa1c05df7a61715ca19921e9cd92abf1f8c84347127c94f724e385e0a36411ffae92341d91d06d679c052c83edb5ab6c49 SHA512 b050d333e021bc3721f5e72c1d2498adea3265afe7f702e1b1e859546755745ac70dcffc194739a4833d4b0b77168506f7fe90fde382d8aab4df2af7b635932b
DIST volume_key-0.3.9.tar.xz 445092 BLAKE2B b9cec52ca02e331501d378482484535413f3ef7675b6592b9f26f272d36448a2ffee1a0ca1c7a552764324ab20cd6dac98447914faafbea96e4c526796bec587 SHA512 bc0e690997b9fa1c9fff361d04e7eddcac4cac09779d7a1f9e161be117f5c589a7e444ac16dab25fb3e3ce201591f7dc937595ddf2745d7daa625d4ab0a255e0
diff --git a/dev-libs/volume_key/files/volume_key-0.3.10-find_python.patch b/dev-libs/volume_key/files/volume_key-0.3.10-find_python.patch
new file mode 100644
index 000000000000..2e76c1d937d6
--- /dev/null
+++ b/dev-libs/volume_key/files/volume_key-0.3.10-find_python.patch
@@ -0,0 +1,55 @@
+From ab21d82bc0186627451d16be45568fcf2b590817 Mon Sep 17 00:00:00 2001
+From: Lars Wendler <polynomial-c@gentoo.org>
+Date: Tue, 22 May 2018 15:08:44 +0200
+Subject: [PATCH] Use pkgconfig to find python
+
+otherwise linkage and include of python fails if python is not in
+default (python$(PYTHON_VERSION)) location.
+---
+ Makefile.am | 4 ++--
+ configure.ac | 7 +++++--
+ 2 files changed, 7 insertions(+), 4 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 68560b1..0bc1a5b 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -20,7 +20,7 @@ ACLOCAL_AMFLAGS = -I m4
+ AM_CPPFLAGS = $(blkid_CFLAGS) $(glib_CFLAGS) $(GPGME_CFLAGS) \
+ $(libcryptsetup_CFLAGS) $(nss_CFLAGS)
+ LOCALEDIR_CPPFLAGS = -DLOCALEDIR='"$(localedir)"'
+-PYTHON_CPPFLAGS = -I/usr/include/python$(PYTHON_VERSION)
++PYTHON_CPPFLAGS = $(PYTHON_CFLAGS)
+
+ ## Targets
+ SUBDIRS = po
+@@ -65,7 +65,7 @@ lib_libvolume_key_la_LIBADD = $(blkid_LIBS) $(glib_LIBS) $(GPGME_LIBS) \
+ python__volume_key_la_SOURCES = python/volume_key_wrap.c
+ python__volume_key_la_CPPFLAGS = $(AM_CPPFLAGS) $(PYTHON_CPPFLAGS)
+ python__volume_key_la_LDFLAGS = -module -avoid-version $(glib_LIBS)
+-python__volume_key_la_LIBADD = lib/libvolume_key.la -lpython$(PYTHON_VERSION) \
++python__volume_key_la_LIBADD = lib/libvolume_key.la $(PYTHON_LIBS) \
+ $(glib_LIBS) $(nss_LIBS)
+
+ src_volume_key_SOURCES = src/volume_key.c
+diff --git a/configure.ac b/configure.ac
+index 40c3906..c9680e4 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -28,8 +28,11 @@ AC_PROG_CC
+ AM_PROG_CC_C_O
+ AM_PROG_AR
+ LT_INIT([disable-static])
+-AC_PATH_PROGS(PYTHON, python2.7 python2.6 python2 python, [Python is required])
+-AM_PATH_PYTHON([2.6], [], AC_MSG_ERROR([Python 2.6 or 2.7 is required]))
++PKG_PROG_PKG_CONFIG
++PKG_CHECK_MODULES(PYTHON, [python], [
++ AM_PATH_PYTHON
++ ], AC_MSG_ERROR([Python is required])
++)
+
+ AC_PATH_PROG([GPG], [gpg2])
+ AC_ARG_VAR([GPG])
+--
+2.17.0
+
diff --git a/dev-libs/volume_key/volume_key-0.3.10.ebuild b/dev-libs/volume_key/volume_key-0.3.10.ebuild
new file mode 100644
index 000000000000..6b38bad452ec
--- /dev/null
+++ b/dev-libs/volume_key/volume_key-0.3.10.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit autotools python-single-r1
+
+DESCRIPTION="Library for manipulating and storing storage volume encryption keys"
+HOMEPAGE="https://pagure.io/volume_key"
+SRC_URI="http://releases.pagure.org/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ app-crypt/gpgme
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ sys-apps/util-linux
+ sys-fs/cryptsetup:=
+"
+DEPEND="
+ ${RDEPEND}
+ sys-devel/gettext
+ test? ( dev-libs/nss[utils] )
+ "
+
+RESTRICT="test" # possible gpgme issue
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.3.10-find_python.patch
+)
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}