summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2017-10-18 07:14:39 +0200
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2017-10-18 07:14:39 +0200
commita14b54660d95f472407ec6d6d6f5e785fd75061e (patch)
tree0b7712a34916aee886d2bef5378b36742291a082 /dev-libs/wayland-protocols/wayland-protocols-1.11.ebuild
parentdev-libs/libinput: version bump to 1.8.3 (diff)
downloadgentoo-a14b54660d95f472407ec6d6d6f5e785fd75061e.tar.gz
gentoo-a14b54660d95f472407ec6d6d6f5e785fd75061e.tar.bz2
gentoo-a14b54660d95f472407ec6d6d6f5e785fd75061e.zip
dev-libs/wayland-protocols: version bump to 1.11
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-libs/wayland-protocols/wayland-protocols-1.11.ebuild')
-rw-r--r--dev-libs/wayland-protocols/wayland-protocols-1.11.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-libs/wayland-protocols/wayland-protocols-1.11.ebuild b/dev-libs/wayland-protocols/wayland-protocols-1.11.ebuild
new file mode 100644
index 000000000000..70049b66d034
--- /dev/null
+++ b/dev-libs/wayland-protocols/wayland-protocols-1.11.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/wayland/wayland-protocols.git"
+ GIT_ECLASS="git-r3"
+ EXPERIMENTAL="true"
+ AUTOTOOLS_AUTORECONF=1
+fi
+
+inherit autotools-utils ${GIT_ECLASS}
+
+DESCRIPTION="Wayland protocol files"
+HOMEPAGE="https://wayland.freedesktop.org/"
+
+if [[ $PV = 9999* ]]; then
+ SRC_URI="${SRC_PATCHES}"
+ KEYWORDS=""
+else
+ SRC_URI="https://wayland.freedesktop.org/releases/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-libs/wayland"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_test() {
+ export XDG_RUNTIME_DIR="${T}/runtime-dir"
+ mkdir "${XDG_RUNTIME_DIR}" || die
+ chmod 0700 "${XDG_RUNTIME_DIR}" || die
+
+ autotools-utils_src_test
+}