summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2018-08-08 12:22:26 -0700
committerMatt Turner <mattst88@gentoo.org>2018-08-08 12:25:17 -0700
commit8e3275ea6398879b0bf3ae2694adc5bff114648c (patch)
tree258e7e148bee44f47bf4633970351e4a45ac7232 /dev-libs/wayland-protocols/wayland-protocols-1.16.ebuild
parentx11-apps/fonttosfnt: Version bump to 1.0.5 (diff)
downloadgentoo-8e3275ea6398879b0bf3ae2694adc5bff114648c.tar.gz
gentoo-8e3275ea6398879b0bf3ae2694adc5bff114648c.tar.bz2
gentoo-8e3275ea6398879b0bf3ae2694adc5bff114648c.zip
dev-libs/wayland-protocols: Version bump to 1.16
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-libs/wayland-protocols/wayland-protocols-1.16.ebuild')
-rw-r--r--dev-libs/wayland-protocols/wayland-protocols-1.16.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-libs/wayland-protocols/wayland-protocols-1.16.ebuild b/dev-libs/wayland-protocols/wayland-protocols-1.16.ebuild
new file mode 100644
index 000000000000..4948be07ff86
--- /dev/null
+++ b/dev-libs/wayland-protocols/wayland-protocols-1.16.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/wayland/wayland-protocols.git"
+ EXPERIMENTAL="true"
+
+ inherit git-r3 autotools
+else
+ inherit autotools
+fi
+
+DESCRIPTION="Wayland protocol files"
+HOMEPAGE="https://wayland.freedesktop.org/"
+
+if [[ $PV != 9999* ]]; then
+ SRC_URI="https://wayland.freedesktop.org/releases/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-libs/wayland"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_test() {
+ export XDG_RUNTIME_DIR="${T}/runtime-dir"
+ mkdir "${XDG_RUNTIME_DIR}" || die
+ chmod 0700 "${XDG_RUNTIME_DIR}" || die
+
+ default
+}