summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-09-18 20:29:49 +0200
committerDavid Seifert <soap@gentoo.org>2016-09-18 22:18:53 +0200
commit28e20b497bfbc42c4ffc5abced934791f282e0c8 (patch)
tree5b738c081c5f45aa4df0f25f206b6274cfd03d91 /dev-libs/xml-security-c/xml-security-c-1.7.3.ebuild
parentkernel-2.eclass: add global EAPI check (diff)
downloadgentoo-28e20b497bfbc42c4ffc5abced934791f282e0c8.tar.gz
gentoo-28e20b497bfbc42c4ffc5abced934791f282e0c8.tar.bz2
gentoo-28e20b497bfbc42c4ffc5abced934791f282e0c8.zip
dev-libs/xml-security-c: Allow for compiling with GCC 6
Gentoo-bug: 594234 * EAPI=6 Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-libs/xml-security-c/xml-security-c-1.7.3.ebuild')
-rw-r--r--dev-libs/xml-security-c/xml-security-c-1.7.3.ebuild17
1 files changed, 7 insertions, 10 deletions
diff --git a/dev-libs/xml-security-c/xml-security-c-1.7.3.ebuild b/dev-libs/xml-security-c/xml-security-c-1.7.3.ebuild
index 7058fa18d4d4..ecd3748b1f61 100644
--- a/dev-libs/xml-security-c/xml-security-c-1.7.3.ebuild
+++ b/dev-libs/xml-security-c/xml-security-c-1.7.3.ebuild
@@ -2,9 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
-
-inherit eutils
+EAPI=6
DESCRIPTION="Apache C++ XML security libraries"
HOMEPAGE="http://santuario.apache.org/"
@@ -25,11 +23,10 @@ DEPEND="${RDEPEND}
virtual/pkgconfig"
DOCS=( CHANGELOG.txt NOTICE.txt )
-
-src_prepare() {
- epatch "${FILESDIR}/1.6.1-nss-compilation-fix.patch"
- epatch_user
-}
+PATCHES=(
+ "${FILESDIR}/${PN}-1.6.1-nss-compilation-fix.patch"
+ "${FILESDIR}/${PN}-1.7.3-fix-c++14.patch"
+)
src_configure() {
econf \
@@ -43,7 +40,7 @@ src_configure() {
src_install() {
default
if use examples ; then
- insinto /usr/share/doc/${PF}/examples
- doins xsec/samples/*.cpp
+ docinto examples
+ dodoc xsec/samples/*.cpp
fi
}