summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James (sam_c) <sam@cmpct.info>2020-05-05 18:37:40 +0000
committerThomas Deutschmann <whissi@gentoo.org>2020-06-17 02:48:12 +0200
commit93d1f0e41b6cc4ee3e00931f8f4243c23153b84a (patch)
treeb41f566764b73d2f098d80f47af7e4bf21ffdbda /dev-libs/xmlsec/xmlsec-1.2.30.ebuild
parentapp-arch/stenc: Version bump to 1.0.8 (diff)
downloadgentoo-93d1f0e41b6cc4ee3e00931f8f4243c23153b84a.tar.gz
gentoo-93d1f0e41b6cc4ee3e00931f8f4243c23153b84a.tar.bz2
gentoo-93d1f0e41b6cc4ee3e00931f8f4243c23153b84a.zip
dev-libs/xmlsec: Bump to 1.2.30
Closes: https://bugs.gentoo.org/721128 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Sam James (sam_c) <sam@cmpct.info> Closes: https://github.com/gentoo/gentoo/pull/15658 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-libs/xmlsec/xmlsec-1.2.30.ebuild')
-rw-r--r--dev-libs/xmlsec/xmlsec-1.2.30.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/dev-libs/xmlsec/xmlsec-1.2.30.ebuild b/dev-libs/xmlsec/xmlsec-1.2.30.ebuild
new file mode 100644
index 000000000000..34308fcbca49
--- /dev/null
+++ b/dev-libs/xmlsec/xmlsec-1.2.30.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Command line tool for signing, verifying, encrypting and decrypting XML"
+HOMEPAGE="https://www.aleksey.com/xmlsec"
+SRC_URI="https://www.aleksey.com/xmlsec/download/${PN}1-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc gcrypt gnutls libressl nss +openssl static-libs test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="|| ( gcrypt gnutls nss openssl )
+ gnutls? ( gcrypt )"
+
+RDEPEND=">=dev-libs/libxml2-2.7.4:=
+ >=dev-libs/libxslt-1.0.20:=
+ gcrypt? ( >=dev-libs/libgcrypt-1.4.0:0= )
+ gnutls? ( >=net-libs/gnutls-2.8.0:= )
+ nss? (
+ >=dev-libs/nspr-4.4.1:=
+ >=dev-libs/nss-3.9:=
+ )
+ openssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ test? (
+ nss? (
+ >=dev-libs/nss-3.9[utils]
+ )
+ )"
+
+S="${WORKDIR}/${PN}1-${PV}"
+
+src_configure() {
+ # Bash because of bug #721128
+ CONFIG_SHELL=${BASH} econf \
+ $(use_enable doc docs) \
+ $(use_enable static-libs static) \
+ $(use_with gcrypt) \
+ $(use_with gnutls) \
+ $(use_with nss nspr) \
+ $(use_with nss) \
+ $(use_with openssl) \
+ --enable-mans \
+ --enable-pkgconfig
+}
+
+src_test() {
+ SHELL=${BASH} emake TMPFOLDER="${T}" check
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}