summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2018-08-19 23:25:43 +0200
committerMichael Weber <xmw@gentoo.org>2018-08-19 23:25:43 +0200
commit8e0a99479df558044065d9040b535bd7068981c1 (patch)
tree31b017639cd1b59953bc38e62626d47708014c8c /dev-libs/yajl/yajl-2.1.0-r1.ebuild
parentapp-text/xmldiff: Version bump, new upstream. (diff)
downloadgentoo-8e0a99479df558044065d9040b535bd7068981c1.tar.gz
gentoo-8e0a99479df558044065d9040b535bd7068981c1.tar.bz2
gentoo-8e0a99479df558044065d9040b535bd7068981c1.zip
dev-libs/yajl: Use EAPI=6, fix build with uclibc (bug 512738).
Thanks a17r and René Rhéaume. Closes: https://github.com/gentoo/gentoo/pull/9620 Closes: https://bugs.gentoo.org/512738 Package-Manager: Portage-2.3.45, Repoman-2.3.10
Diffstat (limited to 'dev-libs/yajl/yajl-2.1.0-r1.ebuild')
-rw-r--r--dev-libs/yajl/yajl-2.1.0-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-libs/yajl/yajl-2.1.0-r1.ebuild b/dev-libs/yajl/yajl-2.1.0-r1.ebuild
new file mode 100644
index 000000000000..003688ade58f
--- /dev/null
+++ b/dev-libs/yajl/yajl-2.1.0-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-multilib vcs-snapshot
+
+DESCRIPTION="Small event-driven (SAX-style) JSON parser"
+HOMEPAGE="https://lloyd.github.com/yajl/"
+SRC_URI="https://github.com/lloyd/yajl/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="static-libs"
+
+PATCHES=( "${FILESDIR}"/${P}-uclibc.patch )
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ multilib_copy_sources
+}
+
+src_test() {
+ run_test() {
+ cd "${BUILD_DIR}"/test/parsing
+ ./run_tests.sh ./yajl_test || die
+ }
+ multilib_parallel_foreach_abi run_test
+}
+
+src_install() {
+ cmake-multilib_src_install
+
+ use static-libs || \
+ find "${D}" -name libyajl_s.a -delete
+}