summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-09-15 09:38:06 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-09-15 09:52:39 +0200
commita6835699c6875089cdfa3b677ec8f407a599bc87 (patch)
treef7a6ed5d08089eede7dac4bcc007e4bef9b2687d /dev-libs/zookeeper-c/zookeeper-c-3.4.9.ebuild
parentdev-libs/ucl: Allow for compiling with GCC 6 (diff)
downloadgentoo-a6835699c6875089cdfa3b677ec8f407a599bc87.tar.gz
gentoo-a6835699c6875089cdfa3b677ec8f407a599bc87.tar.bz2
gentoo-a6835699c6875089cdfa3b677ec8f407a599bc87.zip
dev-libs/zookeeper-c: bump to 3.4.9
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-libs/zookeeper-c/zookeeper-c-3.4.9.ebuild')
-rw-r--r--dev-libs/zookeeper-c/zookeeper-c-3.4.9.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-libs/zookeeper-c/zookeeper-c-3.4.9.ebuild b/dev-libs/zookeeper-c/zookeeper-c-3.4.9.ebuild
new file mode 100644
index 000000000000..c10114160eb1
--- /dev/null
+++ b/dev-libs/zookeeper-c/zookeeper-c-3.4.9.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="C client interface to Zookeeper server"
+HOMEPAGE="https://zookeeper.apache.org/"
+SRC_URI="mirror://apache/zookeeper/zookeeper-${PV}/zookeeper-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc static-libs test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ test? ( dev-util/cppunit )"
+
+S="${WORKDIR}/zookeeper-${PV}/src/c"
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_with test cppunit)
+}
+
+src_compile() {
+ emake
+ use doc && emake doxygen-doc
+}
+
+src_install() {
+ default
+ use doc && dohtml docs/html/*
+}