summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/zthread/zthread-2.3.2-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/zthread/zthread-2.3.2-r1.ebuild')
-rw-r--r--dev-libs/zthread/zthread-2.3.2-r1.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/dev-libs/zthread/zthread-2.3.2-r1.ebuild b/dev-libs/zthread/zthread-2.3.2-r1.ebuild
new file mode 100644
index 000000000000..82b4a7e8e63e
--- /dev/null
+++ b/dev-libs/zthread/zthread-2.3.2-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit eutils autotools
+
+MY_P=ZThread-${PV}
+
+DESCRIPTION="A platform-independent multi-threading and synchronization library for C++"
+HOMEPAGE="http://zthread.sourceforge.net/"
+SRC_URI="mirror://sourceforge/zthread/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 ~hppa ~mips ppc sparc x86"
+IUSE="debug doc kernel_linux static-libs"
+
+DEPEND="doc? ( app-doc/doxygen )"
+RDEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ rm -f include/zthread/{.Barrier.h.swp,Barrier.h.orig} || die
+ epatch "${FILESDIR}"/${P}-no-fpermissive.diff
+
+ AT_M4DIR="share" eautoreconf
+}
+
+src_configure() {
+ local myconf
+ use debug && myconf="--enable-debug"
+
+ econf \
+ $(use_enable kernel_linux atomic-linux) \
+ $(use_enable static-libs static) \
+ ${myconf}
+}
+
+src_compile() {
+ emake || die
+
+ if use doc; then
+ doxygen doc/zthread.doxygen || die
+ cp doc/documentation.html doc/html/index.html || die
+ cp doc/zthread.css doc/html/zthread.css || die
+ cp doc/bugs.js doc/html/bugs.js || die
+ fi
+}
+
+src_install() {
+ einstall || die
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+ use doc && dohtml doc/html/*
+
+ find "${D}" -name '*.la' -delete
+}