summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-01-03 10:54:55 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-01-03 10:55:08 +0100
commit5da92145f220cedef0799c8fadecd430f2046218 (patch)
tree097a93e7ba8e481887688671ff8824658bd19ddb /dev-libs/zziplib
parentmail-mta/courier: Version bump. (diff)
downloadgentoo-5da92145f220cedef0799c8fadecd430f2046218.tar.gz
gentoo-5da92145f220cedef0799c8fadecd430f2046218.tar.bz2
gentoo-5da92145f220cedef0799c8fadecd430f2046218.zip
dev-libs/zziplib: Bump to version 0.13.69
Package-Manager: Portage-2.3.53, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-libs/zziplib')
-rw-r--r--dev-libs/zziplib/Manifest1
-rw-r--r--dev-libs/zziplib/files/zziplib-0.13.69-SDL-test.patch14
-rw-r--r--dev-libs/zziplib/zziplib-0.13.69.ebuild91
3 files changed, 106 insertions, 0 deletions
diff --git a/dev-libs/zziplib/Manifest b/dev-libs/zziplib/Manifest
index acdb84670d26..7ae3c8d24a67 100644
--- a/dev-libs/zziplib/Manifest
+++ b/dev-libs/zziplib/Manifest
@@ -1 +1,2 @@
DIST zziplib-0.13.62.tar.bz2 685770 BLAKE2B 24ef46370cd490498cedeea4b83abffd40b4bf7092ca994defb0c7c90a2c6863c56d19933dca1b20700ed9a55369cd1e8d3f6e1c5ed966b966d15eed4e5b75aa SHA512 fd3b9e9015ba7603bdebd8f6a2ac6d11003705bfab22f3a0025f75455042664aea69440845b59e6f389417dff5ac777f49541d8cbacb2a220e67d20bb6973e25
+DIST zziplib-0.13.69.tar.gz 1132204 BLAKE2B 92e9f5e95665c7a47d1e472f570402e3c174d404abf461bed644ea8a37ff7661ee98b8fa241728aae375e32c470f2f48a817f72410eeda81a6a3be6e6bdb2635 SHA512 ade026289737f43ca92a8746818d87dd7618d473dbce159546ce9071c9e4cbe164a6b1c9efff16efb7aa0327b2ec6b34f3256c6bda19cd6e325703fffc810ef0
diff --git a/dev-libs/zziplib/files/zziplib-0.13.69-SDL-test.patch b/dev-libs/zziplib/files/zziplib-0.13.69-SDL-test.patch
new file mode 100644
index 000000000000..7f85b6864696
--- /dev/null
+++ b/dev-libs/zziplib/files/zziplib-0.13.69-SDL-test.patch
@@ -0,0 +1,14 @@
+this test isnt even run automatically and the dependencies are all broken,
+so just disable it and be done
+
+--- zziplib-0.13.69/SDL/Makefile.am
++++ zziplib-0.13.69/SDL/Makefile.am
+@@ -5,7 +5,7 @@
+ zzipsdl_DATA = SDL_rwops_zzip.c SDL_rwops_zzip.h
+
+ EXTRA_DIST = $(sdl_DATA)
+-check_PROGRAMS = zzcatsdl
++check_PROGRAMS =
+
+ zzcatsdl_SOURCES = SDL_rwops_zzcat.c SDL_rwops_zzip.c
+ ZZIP_CFLAGS= `export PKG_CONFIG_PATH=../zzip; pkg-config zziplib --cflags`
diff --git a/dev-libs/zziplib/zziplib-0.13.69.ebuild b/dev-libs/zziplib/zziplib-0.13.69.ebuild
new file mode 100644
index 000000000000..973505427e73
--- /dev/null
+++ b/dev-libs/zziplib/zziplib-0.13.69.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools libtool flag-o-matic python-any-r1
+
+DESCRIPTION="Lightweight library for extracting data from files archived in a single zip file"
+HOMEPAGE="http://zziplib.sourceforge.net/"
+SRC_URI="https://github.com/gdraheim/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc sdl static-libs test"
+
+RDEPEND="
+ sys-libs/zlib
+ sdl? ( >=media-libs/libsdl-1.2.6 )"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+ test? ( app-arch/zip )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.13.69-SDL-test.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+
+ python_fix_shebang .
+
+ # workaround AX_CREATE_PKGCONFIG_INFO bug #353195
+ sed -i \
+ -e '/ax_create_pkgconfig_ldflags/s:$LDFLAGS::' \
+ -e '/ax_create_pkgconfig_cppflags/s:$CPPFLAGS::' \
+ configure || die
+
+ # zziplib tries to install backwards compat symlinks we dont want
+ sed -i -e '/^zzip-postinstall:/s|$|\ndisable-this:|' Makefile.in || die
+ sed -i -e '/^install-exec-hook:/s|$|\ndisable-this:|' zzip/Makefile.in || die
+
+ elibtoolize
+
+ # Do an out-of-tree build as their configure will do it automatically
+ # otherwise and that can lead to funky errors. #492816
+ mkdir -p build
+}
+
+src_configure() {
+ cd "${S}"/build
+
+ append-flags -fno-strict-aliasing # bug reported upstream
+ export ac_cv_path_XMLTO= # man pages are bundled in .tar's
+
+ local myeconfargs=(
+ $(use_enable sdl)
+ $(use_enable static-libs static)
+ )
+
+ # Disable aclocal probing as the default path works #449156
+ ECONF_SOURCE=${S} ACLOCAL=true \
+ econf "${myeconfargs[@]}"
+ MAKEOPTS+=' -C build'
+}
+
+src_install() {
+ default
+
+ # fowners fails when we don't have enough permissions (Prefix)
+ if [[ ${EUID} == 0 ]] ; then
+ fowners -R root /usr/share/man #321975
+ fi
+
+ find "${ED}" -name "*.la" -delete || die
+
+ if use doc ; then
+ docinto html
+ dodoc -r docs/*
+ fi
+}
+
+src_test() {
+ # need this because `make test` will always return true
+ # tests fail with -j > 1 (bug #241186)
+ emake -j1 check
+}