summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2021-06-07 15:31:13 -0400
committerMike Gilbert <floppym@gentoo.org>2021-06-07 15:31:13 -0400
commit0ee60b97e7f653fc0cb54ac03809c07ba6c092aa (patch)
treeff8bad3d488656231e5a817760f0f195e89d0742 /dev-libs
parentwww-client/microsoft-edge-dev: remove old (diff)
downloadgentoo-0ee60b97e7f653fc0cb54ac03809c07ba6c092aa.tar.gz
gentoo-0ee60b97e7f653fc0cb54ac03809c07ba6c092aa.tar.bz2
gentoo-0ee60b97e7f653fc0cb54ac03809c07ba6c092aa.zip
dev-libs/openssl: be more careful when removing static libs
Avoids removing .dll.a files necessary for linking on mingw. Closes: https://bugs.gentoo.org/792318 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/openssl/openssl-1.0.2u.ebuild16
-rw-r--r--dev-libs/openssl/openssl-1.1.1k.ebuild16
2 files changed, 18 insertions, 14 deletions
diff --git a/dev-libs/openssl/openssl-1.0.2u.ebuild b/dev-libs/openssl/openssl-1.0.2u.ebuild
index b7b3fba6c2ed..65c297883822 100644
--- a/dev-libs/openssl/openssl-1.0.2u.ebuild
+++ b/dev-libs/openssl/openssl-1.0.2u.ebuild
@@ -248,6 +248,15 @@ multilib_src_install() {
fi
emake INSTALL_PREFIX="${D}" install
+
+ # This is crappy in that the static archives are still built even
+ # when USE=static-libs. But this is due to a failing in the openssl
+ # build system: the static archives are built as PIC all the time.
+ # Only way around this would be to manually configure+compile openssl
+ # twice; once with shared lib support enabled and once without.
+ if ! use static-libs; then
+ rm "${ED}"/usr/$(get_libdir)/lib{crypto,ssl}.a || die
+ fi
}
multilib_src_install_all() {
@@ -260,13 +269,6 @@ multilib_src_install_all() {
use rfc3779 && dodoc engines/ccgost/README.gost
- # This is crappy in that the static archives are still built even
- # when USE=static-libs. But this is due to a failing in the openssl
- # build system: the static archives are built as PIC all the time.
- # Only way around this would be to manually configure+compile openssl
- # twice; once with shared lib support enabled and once without.
- use static-libs || rm -f "${ED}"/usr/lib*/lib*.a
-
# create the certs directory
dodir ${SSL_CNF_DIR}/certs
cp -RP certs/* "${ED}"${SSL_CNF_DIR}/certs/ || die
diff --git a/dev-libs/openssl/openssl-1.1.1k.ebuild b/dev-libs/openssl/openssl-1.1.1k.ebuild
index 9b4eaf0e7a62..1e98af8f7039 100644
--- a/dev-libs/openssl/openssl-1.1.1k.ebuild
+++ b/dev-libs/openssl/openssl-1.1.1k.ebuild
@@ -270,6 +270,15 @@ multilib_src_install() {
fi
emake DESTDIR="${D}" install
+
+ # This is crappy in that the static archives are still built even
+ # when USE=static-libs. But this is due to a failing in the openssl
+ # build system: the static archives are built as PIC all the time.
+ # Only way around this would be to manually configure+compile openssl
+ # twice; once with shared lib support enabled and once without.
+ if ! use static-libs; then
+ rm "${ED}"/usr/$(get_libdir)/lib{crypto,ssl}.a || die
+ fi
}
multilib_src_install_all() {
@@ -279,13 +288,6 @@ multilib_src_install_all() {
dodoc CHANGES* FAQ NEWS README doc/*.txt doc/${PN}-c-indent.el
- # This is crappy in that the static archives are still built even
- # when USE=static-libs. But this is due to a failing in the openssl
- # build system: the static archives are built as PIC all the time.
- # Only way around this would be to manually configure+compile openssl
- # twice; once with shared lib support enabled and once without.
- use static-libs || rm -f "${ED}"/usr/lib*/lib*.a
-
# create the certs directory
keepdir ${SSL_CNF_DIR}/certs