summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-06-14 08:56:50 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2021-06-14 08:57:03 -0500
commit204589defdceebfc8bee7982fef54012b71e67f0 (patch)
tree479abc270916d06f386729c8019655371d463286 /dev-libs
parentnet-p2p/energi3: disable tests (diff)
downloadgentoo-204589defdceebfc8bee7982fef54012b71e67f0.tar.gz
gentoo-204589defdceebfc8bee7982fef54012b71e67f0.tar.bz2
gentoo-204589defdceebfc8bee7982fef54012b71e67f0.zip
dev-libs/leatherman: switch to cmake from cmake-utils
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/leatherman/leatherman-1.12.5.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-libs/leatherman/leatherman-1.12.5.ebuild b/dev-libs/leatherman/leatherman-1.12.5.ebuild
index 7f68e10d0d21..c105fc67cf23 100644
--- a/dev-libs/leatherman/leatherman-1.12.5.ebuild
+++ b/dev-libs/leatherman/leatherman-1.12.5.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="A C++ toolkit"
HOMEPAGE="https://github.com/puppetlabs/leatherman"
@@ -27,7 +27,7 @@ PATCHES+=( "${FILESDIR}"/1.12.2-shared_nowide.patch )
src_prepare() {
sed -i 's/\-Werror\ //g' "cmake/cflags.cmake" || die
# vendored boost lib conflicts with boost 1.73 and above
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
@@ -49,7 +49,7 @@ src_configure() {
-DCMAKE_BUILD_TYPE=Debug
)
fi
- cmake-utils_src_configure
+ cmake_src_configure
}
src_test() {
@@ -57,5 +57,5 @@ src_test() {
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
}