summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2017-02-04 00:34:53 +0200
committerAlon Bar-Lev <alonbl@gentoo.org>2017-02-04 03:30:44 +0200
commit27180410d5b72690f8b58be5128801135fc18413 (patch)
treed3ab23ef8d46a91133756a81bbb59b22d807db08 /dev-libs
parentdev-libs/openct: eapi bump (diff)
downloadgentoo-27180410d5b72690f8b58be5128801135fc18413.tar.gz
gentoo-27180410d5b72690f8b58be5128801135fc18413.tar.bz2
gentoo-27180410d5b72690f8b58be5128801135fc18413.zip
dev-libs/libmcrypt: eapi bump
Package-Manager: portage-2.3.3
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libmcrypt/files/libmcrypt-2.5.8-rotate-mask.patch6
-rw-r--r--dev-libs/libmcrypt/libmcrypt-2.5.8-r4.ebuild37
2 files changed, 40 insertions, 3 deletions
diff --git a/dev-libs/libmcrypt/files/libmcrypt-2.5.8-rotate-mask.patch b/dev-libs/libmcrypt/files/libmcrypt-2.5.8-rotate-mask.patch
index ca31df4b2719..568caa463862 100644
--- a/dev-libs/libmcrypt/files/libmcrypt-2.5.8-rotate-mask.patch
+++ b/dev-libs/libmcrypt/files/libmcrypt-2.5.8-rotate-mask.patch
@@ -1,9 +1,9 @@
---- KNOWN-BUGS 2008-12-13 15:31:49.000000000 -0500
+--- a/KNOWN-BUGS 2008-12-13 15:31:49.000000000 -0500
+++ /dev/null 2008-12-13 02:05:21.751517562 -0500
@@ -1 +0,0 @@
-- cast-256 and rc6 do not work properly on Alpha (64 bit) machines
---- lib/mcrypt_modules.h.orig 2008-12-13 15:33:06.000000000 -0500
-+++ lib/mcrypt_modules.h 2008-12-13 15:25:01.000000000 -0500
+--- a/lib/mcrypt_modules.h.orig 2008-12-13 15:33:06.000000000 -0500
++++ b/lib/mcrypt_modules.h 2008-12-13 15:25:01.000000000 -0500
@@ -1,7 +1,7 @@
-#define rotl32(x,n) (((x) << ((word32)(n))) | ((x) >> (32 - (word32)(n))))
-#define rotr32(x,n) (((x) >> ((word32)(n))) | ((x) << (32 - (word32)(n))))
diff --git a/dev-libs/libmcrypt/libmcrypt-2.5.8-r4.ebuild b/dev-libs/libmcrypt/libmcrypt-2.5.8-r4.ebuild
new file mode 100644
index 000000000000..497cff9510ba
--- /dev/null
+++ b/dev-libs/libmcrypt/libmcrypt-2.5.8-r4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+inherit autotools eutils
+
+DESCRIPTION="libmcrypt provides uniform interface to access several encryption algorithms"
+HOMEPAGE="http://mcrypt.sourceforge.net/"
+SRC_URI="mirror://sourceforge/mcrypt/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+DOCS=(
+ AUTHORS NEWS README THANKS TODO ChangeLog
+ doc/README.config doc/README.key doc/README.xtea
+ doc/example.c
+)
+
+PATCHES=(
+ "${FILESDIR}/${P}-rotate-mask.patch"
+)
+
+src_prepare() {
+ default
+ mv configure.in configure.ac
+ mv libltdl/configure.in libltdl/configure.ac
+ sed -i 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' configure.ac libltdl/configure.ac || die
+ eautoreconf # need new libtool for interix (elibtoolize would suffice for freebsd)
+}