summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-12-11 17:05:42 +0100
committerThomas Deutschmann <whissi@gentoo.org>2018-12-11 17:32:15 +0100
commit2bbab8936408075202f6d7028b9903dd25722492 (patch)
tree4bf61bd2d12d4941f520899588e13640bb425f22 /dev-libs
parentx11-base/xorg-drivers: [QA] Remove support for removed xf86-*-tslib (diff)
downloadgentoo-2bbab8936408075202f6d7028b9903dd25722492.tar.gz
gentoo-2bbab8936408075202f6d7028b9903dd25722492.tar.bz2
gentoo-2bbab8936408075202f6d7028b9903dd25722492.zip
dev-libs/librelp: bump to v1.3.0
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/librelp/Manifest1
-rw-r--r--dev-libs/librelp/files/librelp-1.3.0-dummyclient.py-Py3-compatibility.patch24
-rw-r--r--dev-libs/librelp/librelp-1.3.0.ebuild85
3 files changed, 110 insertions, 0 deletions
diff --git a/dev-libs/librelp/Manifest b/dev-libs/librelp/Manifest
index 487a22d06ded..ad864b14fd96 100644
--- a/dev-libs/librelp/Manifest
+++ b/dev-libs/librelp/Manifest
@@ -1,3 +1,4 @@
DIST librelp-1.2.16.tar.gz 474456 BLAKE2B b528aaa66e9d52d5304510f86400067e1baea44be487f8cb176aeb146924bc35af24a403e849376e74614fb060093b48a3afe9d6c5da56bbf4dc37a6740478cc SHA512 54c101281c94046e4f8d6f77e73ab52874408e62c77f3dfa29ec0b294f39c216637674cc0bf1b7e04173557b3f21bfa74b7be1aafa3ff2771acd41d1d067d3a3
DIST librelp-1.2.17.tar.gz 506426 BLAKE2B 998d2845263655a43d0cb002c4538663047f2e07f62d6a870bf93e435c4b2d100a3cc9e4ab711233e9c1f73aedd8771e116b7c7139d2ad6d1baa7c483b2867a1 SHA512 4f69d3e4bc3052c0488a01def49dab16b54fc4a092e06f8776415cb1eca2282702a37497e43baf98fc038853d373116d6b58515c9ad91fae91fb3eb84706890f
DIST librelp-1.2.18.tar.gz 506766 BLAKE2B 939bd2279e03a6431fbdfb787aa3d62b3f622ec3248dfc7c0a0a141294c27319081092a624c328374cdba0cbd51659301a77ad41bed27ba13f47601f7a607944 SHA512 7193438238b7019e7a4944d6d900a1fa5a369ff8a6b97a6dca7e82b6637c0f391ec3554eeeaa285881457cb2abe72fa1a893244ec9a36cc9d2e2592d58c5462a
+DIST librelp-1.3.0.tar.gz 514470 BLAKE2B 3e8d844d3cccd4c148036191f376ba49b3851a2c7e95361bb31a1a172ca0813caa96eb3753b2285a2547c85e073de3237a749bc64fc0fead69ab170656dcb200 SHA512 6e60398c68a78f4b4202a697e144f1516ff3bbb32192f745b52c77d107954febf8cb31d2e166efa96c00122f6807860ecd01084f1d3d4005336f2cb75e6461c9
diff --git a/dev-libs/librelp/files/librelp-1.3.0-dummyclient.py-Py3-compatibility.patch b/dev-libs/librelp/files/librelp-1.3.0-dummyclient.py-Py3-compatibility.patch
new file mode 100644
index 000000000000..99ac9887f739
--- /dev/null
+++ b/dev-libs/librelp/files/librelp-1.3.0-dummyclient.py-Py3-compatibility.patch
@@ -0,0 +1,24 @@
+From 93c7ab4284f0609abab7cf2f9b8bdefe21fe0038 Mon Sep 17 00:00:00 2001
+From: Thomas Deutschmann <whissi@whissi.de>
+Date: Tue, 11 Dec 2018 16:50:12 +0100
+Subject: [PATCH] tests: make dummyclient.py compatible with Python2 and
+ Python3
+
+Closes: https://github.com/rsyslog/librelp/issues/163
+---
+ tests/dummyclient.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/dummyclient.py b/tests/dummyclient.py
+index 6f99c79..8b0041e 100755
+--- a/tests/dummyclient.py
++++ b/tests/dummyclient.py
+@@ -4,7 +4,7 @@
+ import os
+
+ port = int(os.environ['TESTPORT'])
+-print "dummyclient info: opening and closing port " + str(port) + " without sending data"
++print("dummyclient info: opening and closing port " + str(port) + " without sending data")
+ s = socket.socket(socket.AF_INET, socket.SOCK_STREAM)
+ s.connect(("127.0.0.1", port))
+ s.close()
diff --git a/dev-libs/librelp/librelp-1.3.0.ebuild b/dev-libs/librelp/librelp-1.3.0.ebuild
new file mode 100644
index 000000000000..4024aa27d04a
--- /dev/null
+++ b/dev-libs/librelp/librelp-1.3.0.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit autotools python-any-r1
+
+DESCRIPTION="An easy to use library for the RELP protocol"
+HOMEPAGE="http://www.librelp.com/"
+SRC_URI="http://download.rsyslog.com/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+ doc? ( FDL-1.3 )"
+
+# subslot = soname version
+SLOT="0/0.4.0"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~sparc ~x86"
+IUSE="debug doc +ssl +gnutls libressl openssl static-libs test"
+REQUIRED_USE="ssl? ( ^^ ( gnutls openssl ) )
+ gnutls? ( ssl )
+ openssl? ( ssl )
+ libressl? ( openssl )"
+
+RDEPEND="ssl? (
+ gnutls? ( >=net-libs/gnutls-3.3.17.1:0= )
+ openssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+ )"
+
+DEPEND="ssl? (
+ gnutls? ( >=net-libs/gnutls-3.3.17.1:0= )
+ openssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+ )
+ test? ( ${PYTHON_DEPS} )
+ virtual/pkgconfig"
+
+RESTRICT="!test? ( test )"
+
+PATCHES=( "${FILESDIR}"/${P}-dummyclient.py-Py3-compatibility.patch )
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ sed -i \
+ -e 's/ -g"/"/g' \
+ configure.ac || die "sed failed"
+
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-valgrind
+ $(use_enable debug)
+ $(use_enable gnutls tls)
+ $(use_enable openssl tls-openssl)
+ $(use_enable static-libs static)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ emake -j1 check
+}
+
+src_install() {
+ local DOCS=( ChangeLog )
+ use doc && local HTML_DOCS=( doc/relp.html )
+ default
+
+ if ! use static-libs; then
+ find "${ED%/}"/usr/lib* -name '*.la' -delete || die
+ fi
+}