summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-15 03:19:47 +0000
committerSam James <sam@gentoo.org>2021-06-15 03:19:47 +0000
commit35f3c535b370e4965ae9d5c40021767029f91122 (patch)
tree357a883e23a444faea3bb9425563b2244ea1b332 /dev-libs
parentdev-lang/maude: fix build with GCC 11 (diff)
downloadgentoo-35f3c535b370e4965ae9d5c40021767029f91122.tar.gz
gentoo-35f3c535b370e4965ae9d5c40021767029f91122.tar.bz2
gentoo-35f3c535b370e4965ae9d5c40021767029f91122.zip
dev-libs/xapian: workaround build failure with GCC 11 for 1.2.25
Force C++14 for now. This is an older version we'll be cleaning up soon, but we may as well let it build. Newer versions are fine. (Also, this style of error usually results in a noisy patch.) Closes: https://bugs.gentoo.org/789390 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/xapian/xapian-1.2.25.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-libs/xapian/xapian-1.2.25.ebuild b/dev-libs/xapian/xapian-1.2.25.ebuild
index 6fb5b4472847..c756a3c880b6 100644
--- a/dev-libs/xapian/xapian-1.2.25.ebuild
+++ b/dev-libs/xapian/xapian-1.2.25.ebuild
@@ -3,7 +3,7 @@
EAPI="6"
-inherit multilib-minimal
+inherit flag-o-matic multilib-minimal
MY_P="${PN}-core-${PV}"
@@ -24,6 +24,10 @@ S="${WORKDIR}/${MY_P}"
multilib_src_configure() {
local myconf=""
+ # "brass_check.cc:40:48: error: reference to ‘byte’ is ambiguous"
+ # bug #789390
+ append-cxxflags -std=c++14
+
if use cpu_flags_x86_sse2; then
myconf="${myconf} --enable-sse=sse2"
else