summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2017-09-29 08:14:38 +0200
committerMichael Weber <xmw@gentoo.org>2017-09-29 08:14:38 +0200
commit385bd19a89ff658345c56f531e6b996a68a06559 (patch)
treed0fae5c77ba81dc8dc7af9b64d1ab8a7a938ec45 /dev-libs
parentdev-util/waf: Version bump. (diff)
downloadgentoo-385bd19a89ff658345c56f531e6b996a68a06559.tar.gz
gentoo-385bd19a89ff658345c56f531e6b996a68a06559.tar.bz2
gentoo-385bd19a89ff658345c56f531e6b996a68a06559.zip
dev-libs/libcxml: Add live version for current dcpomatic.
Package-Manager: Portage-2.3.10, Repoman-2.3.3
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libcxml/libcxml-9999.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-libs/libcxml/libcxml-9999.ebuild b/dev-libs/libcxml/libcxml-9999.ebuild
new file mode 100644
index 000000000000..acb40482573c
--- /dev/null
+++ b/dev-libs/libcxml/libcxml-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )
+PYTHON_REQ_USE="threads(+)"
+inherit git-r3 python-any-r1 waf-utils
+
+DESCRIPTION="small C++ library which makes it marginally neater to parse XML using libxml++"
+HOMEPAGE="http://carlh.net/libcxml"
+EGIT_REPO_URI="https://github.com/cth103/${PN}.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="dev-cpp/libxmlpp:2.6
+ dev-libs/boost
+ dev-libs/locked_sstream"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ dev-util/waf
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.15.1-respect-cxxflags.patch )
+
+src_prepare() {
+ rm -v waf || die
+ export WAF_BINARY="${EROOT}usr/bin/waf"
+
+ default
+}
+
+src_test() {
+ ./run-tests.sh || die
+}