summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2021-02-17 11:23:27 +0300
committerSergey Popov <pinkbyte@gentoo.org>2021-02-17 11:24:15 +0300
commit3925c99dae76d338c90f7d217bf6a00c9e515469 (patch)
treee5e425a2c970d95037b64da4b48e1430161cafad /dev-libs
parentdev-util/diffuse: bump to 0.6.0 (diff)
downloadgentoo-3925c99dae76d338c90f7d217bf6a00c9e515469.tar.gz
gentoo-3925c99dae76d338c90f7d217bf6a00c9e515469.tar.bz2
gentoo-3925c99dae76d338c90f7d217bf6a00c9e515469.zip
dev-libs/jthread: bump EAPI to 7
Switch from cmake-utils to cmake eclass Reported-by: Andreas Sturmlechner <asturm@gentoo.org> Closes: https://bugs.gentoo.org/770583 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Sergey Popov <pinkbyte@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/jthread/jthread-1.3.3.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/dev-libs/jthread/jthread-1.3.3.ebuild b/dev-libs/jthread/jthread-1.3.3.ebuild
index 165ed9f222d5..3a5c2032dd48 100644
--- a/dev-libs/jthread/jthread-1.3.3.ebuild
+++ b/dev-libs/jthread/jthread-1.3.3.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+CMAKE_ECLASS=cmake
inherit cmake-multilib
DESCRIPTION="JThread provides some classes to make use of threads easy on different platforms"
@@ -22,5 +23,5 @@ src_prepare() {
if ! use static-libs; then
sed -i -e '/jthread-static/d' src/CMakeLists.txt || die 'sed on src/CMakeLists.txt failed'
fi
- cmake-utils_src_prepare
+ cmake_src_prepare
}