summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2017-11-24 06:57:01 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-12-07 18:33:06 +0100
commit3a2946cb04fefc024f1a4b416185150903812377 (patch)
treeabcaf5e2878ec3b4d2ab87bbc83c2d17e33a78b8 /dev-libs
parentdev-libs/libbson: version bump to 1.8.2. (diff)
downloadgentoo-3a2946cb04fefc024f1a4b416185150903812377.tar.gz
gentoo-3a2946cb04fefc024f1a4b416185150903812377.tar.bz2
gentoo-3a2946cb04fefc024f1a4b416185150903812377.zip
dev-libs/mongo-c-driver: version bump to 1.8.2.
Closes: https://bugs.gentoo.org/635728 Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/mongo-c-driver/Manifest1
-rw-r--r--dev-libs/mongo-c-driver/mongo-c-driver-1.8.2.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/dev-libs/mongo-c-driver/Manifest b/dev-libs/mongo-c-driver/Manifest
index 0f114832b4c7..130390d1160c 100644
--- a/dev-libs/mongo-c-driver/Manifest
+++ b/dev-libs/mongo-c-driver/Manifest
@@ -5,3 +5,4 @@ DIST mongo-c-driver-1.1.10.tar.gz 5321144 SHA256 19c076fcca1e7b22a731f10b757a049
DIST mongo-c-driver-1.1.2.tar.gz 5443153 SHA256 ba97f4304883abf6d57ac96751260c4b413b871b0779c12e67136320bee5f118 SHA512 d420fc407f6a04c06a959b8971dc2643c987df5c3d82f2b13bfdf6a44e96bc377478c4d0e385abf67f21b56892c915c79675fe9ebf6efa9aab51fe452c5e6f95 WHIRLPOOL d72bdd7e449e8437bc9742e5f0330e6f6c47d40e3fc07a17d95a9967ecb2ae5961f5c7c155e2d8a12e733139ffbf30091dfa283f6f6a694e05c9c9fb7a03bd2b
DIST mongo-c-driver-1.3.5.tar.gz 5860804 SHA256 374d37a6d6e49fbb2ed6cab0a305ced347651ec04d57808961d03afa8caa68df SHA512 23844ffe20580998308aa9c8409afcb87dccde874077eefc6806b705e5de5743846ba0513f3a3fe83147fc47842ab8c7438ad1de5f3f55b81586b9e19046aabf WHIRLPOOL 6583ba6e93e15ba025232bed1bb1964e85a90695d340d14c873fee26c0c9229d66eb1acfe53e718957210c2dbec67bfc06a1b7b95a9ed4dce0fe8cdad138ac6e
DIST mongo-c-driver-1.6.2.tar.gz 6907818 SHA256 7ec27e9be4da2bf9e4b316374f8c29f816f0a0f019b984411777e9681e17f70e SHA512 b3fe08a31bc83707a4d94f8ea2742fc9b17d024d6c2f92b49cfc4fe012e58cd441c9f0fa4bae9f4205fca44b2a0d8c6d5bc32a05fc9ede9bab0011839a1394af WHIRLPOOL f973aff4c7f457d6b7d61f4e015ed2bcdc1f4668506eb267e15891144a790f6cf2f4a660bb21cc70c63cd91d388cb5b2b323476d55f05243c3d5a5f8c89df37d
+DIST mongo-c-driver-1.8.2.tar.gz 7308675 BLAKE2B ca82c2824486cee78b164d1fdfcf1de062804f0f8637a36ec197efe434ae23a387ec0e6b2e4aa3e9c8bb2434a3cef48fecd17fc4b159a92ad86b8b940b17598a SHA512 af23601ba33694d80acdb890c1b85a354fda966491c4bbfb341a884bcd6314886e405efa3a09e47398adf8dbfdeb1b05ae8b022a72f04a66265bfaeddb661f76
diff --git a/dev-libs/mongo-c-driver/mongo-c-driver-1.8.2.ebuild b/dev-libs/mongo-c-driver/mongo-c-driver-1.8.2.ebuild
new file mode 100644
index 000000000000..86291cab07b9
--- /dev/null
+++ b/dev-libs/mongo-c-driver/mongo-c-driver-1.8.2.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A high-performance MongoDB driver for C"
+HOMEPAGE="https://github.com/mongodb/mongo-c-driver"
+SRC_URI="https://github.com/mongodb/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="debug examples libressl sasl ssl static-libs test"
+
+RDEPEND="app-arch/snappy:=
+ >=dev-libs/libbson-1.8.2
+ sys-libs/zlib:=
+ sasl? ( dev-libs/cyrus-sasl )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )"
+DEPEND="${RDEPEND}
+ test? ( dev-db/mongodb )"
+
+src_prepare() {
+ # remove bundled libs
+ rm -rv src/{libbson,zlib*} || die
+
+ # bundled headers are gone
+ sed -e '/^ac_config_files/s@src/zlib-.*/zconf.h@@g' \
+ -i configure || die
+
+ # this test fails
+ sed -e '/test_topology_install (&suite)/d' \
+ -i tests/test-libmongoc.c || die
+
+ default
+}
+
+src_configure() {
+ econf --with-libbson=system \
+ --with-snappy=system \
+ --with-zlib=system \
+ --disable-optimizations \
+ --disable-shm-counters \
+ --disable-examples \
+ --docdir="${EPREFIX}/usr/share/doc/${P}" \
+ $(use_enable sasl) \
+ $(use_enable ssl ssl $(usex libressl libressl openssl)) \
+ $(use_enable debug) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default_src_install
+
+ # Only install the mongoc man pages to avoid conflicts of common names
+ doman doc/man/mongoc_*.3
+
+ if ! use static-libs; then
+ find "${D}" -name '*.la' -delete || die
+ fi
+
+ if use examples; then
+ docinto examples
+ dodoc -r examples/*.c examples/aggregation examples/bulk
+ fi
+}
+
+src_test() {
+ # Avoid allocating too much disk space by using server.smallFiles = 1
+ echo -e "storage:\n smallFiles: true" > "${T}/mongod.conf" || die
+ local PORT=27099
+ mongod --port ${PORT} --bind_ip 127.0.0.1 --nounixsocket --fork \
+ -f "${T}/mongod.conf" --dbpath="${T}" \
+ --logpath="${T}/mongod.log" || die
+ MONGOC_TEST_HOST="127.0.0.1:${PORT}" emake test
+ kill $(<"${T}/mongod.lock")
+}