summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-11-17 21:24:07 +0200
committerMart Raudsepp <leio@gentoo.org>2019-11-17 21:24:41 +0200
commit3ac079a6cd86e6c959a54b136f36902516c4f417 (patch)
tree31d253d551fc71ed560e67580b2a1d00b6fb3336 /dev-libs
parentdev-db/pspg: Bump to 2.5.5 (diff)
downloadgentoo-3ac079a6cd86e6c959a54b136f36902516c4f417.tar.gz
gentoo-3ac079a6cd86e6c959a54b136f36902516c4f417.tar.bz2
gentoo-3ac079a6cd86e6c959a54b136f36902516c4f417.zip
dev-libs/gmime:2.6: drop mono bindings support
There are issues with the mono support with 17.1 profiles. As this is an old legacy SLOT and there are no in-tree consumers of these bindings, just drop them instead of bothering proper fixing. Closes: https://bugs.gentoo.org/688666 Package-Manager: Portage-2.3.69, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/gmime/gmime-2.6.23-r1.ebuild (renamed from dev-libs/gmime/gmime-2.6.23.ebuild)18
1 files changed, 5 insertions, 13 deletions
diff --git a/dev-libs/gmime/gmime-2.6.23.ebuild b/dev-libs/gmime/gmime-2.6.23-r1.ebuild
index fe5a962ae414..21d44a9d7d81 100644
--- a/dev-libs/gmime/gmime-2.6.23.ebuild
+++ b/dev-libs/gmime/gmime-2.6.23-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=6
VALA_USE_DEPEND="vapigen"
-inherit mono-env gnome2 vala flag-o-matic
+inherit gnome2 vala flag-o-matic
DESCRIPTION="Utilities for creating and parsing messages using MIME"
HOMEPAGE="http://spruce.sourceforge.net/gmime/ https://developer.gnome.org/gmime/stable/"
@@ -12,14 +12,11 @@ HOMEPAGE="http://spruce.sourceforge.net/gmime/ https://developer.gnome.org/gmime
SLOT="2.6"
LICENSE="LGPL-2.1"
KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE="doc mono smime static-libs test vala"
+IUSE="doc smime static-libs test vala"
RDEPEND="
>=dev-libs/glib-2.32.0:2
sys-libs/zlib
- mono? (
- dev-lang/mono
- >=dev-dotnet/gtk-sharp-2.12.21:2 )
smime? ( >=app-crypt/gpgme-1.1.6:1= )
vala? (
$(vala_depend)
@@ -34,10 +31,6 @@ DEPEND="${RDEPEND}
"
# gnupg is needed for tests if --enable-cryptography is enabled, which we do unconditionally
-pkg_setup() {
- use mono && mono-env_pkg_setup
-}
-
src_prepare() {
gnome2_src_prepare
use vala && vala_src_prepare
@@ -48,22 +41,21 @@ src_configure() {
gnome2_src_configure \
--enable-cryptography \
--disable-strict-parser \
- $(use_enable mono) \
+ --disable-mono \
$(use_enable smime) \
$(use_enable static-libs static) \
$(use_enable vala)
}
src_compile() {
- MONO_PATH="${S}" gnome2_src_compile
+ gnome2_src_compile
if use doc; then
emake -C docs/tutorial html
fi
}
src_install() {
- GACUTIL_FLAGS="/root '${ED}/usr/$(get_libdir)' /gacdir '${EPREFIX}/usr/$(get_libdir)' /package ${PN}" \
- gnome2_src_install
+ gnome2_src_install
if use doc ; then
docinto tutorial