summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-24 15:36:31 +0100
committerSam James <sam@gentoo.org>2022-10-24 16:51:53 +0100
commit3bb07c1c0ddc91c019d9406c45796391525af5c8 (patch)
treea8b0b0c4f09f031197f990d63b4d084c9741c604 /dev-libs
parentnet-misc/dhcp: Adding acct-user/dhcp and acct-group/dhcp to BDPEND (diff)
downloadgentoo-3bb07c1c0ddc91c019d9406c45796391525af5c8.tar.gz
gentoo-3bb07c1c0ddc91c019d9406c45796391525af5c8.tar.bz2
gentoo-3bb07c1c0ddc91c019d9406c45796391525af5c8.zip
dev-libs/libucl: fix build with USE=-lua
Closes: https://bugs.gentoo.org/878031 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libucl/libucl-0.8.1-r100.ebuild8
-rw-r--r--dev-libs/libucl/libucl-9999.ebuild8
2 files changed, 10 insertions, 6 deletions
diff --git a/dev-libs/libucl/libucl-0.8.1-r100.ebuild b/dev-libs/libucl/libucl-0.8.1-r100.ebuild
index 2eb9fa97c158..8b3e4c0b5cc2 100644
--- a/dev-libs/libucl/libucl-0.8.1-r100.ebuild
+++ b/dev-libs/libucl/libucl-0.8.1-r100.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -35,6 +35,10 @@ RDEPEND="${DEPEND}"
DOCS=( README.md doc/api.md )
+pkg_setup() {
+ use lua && lua_pkg_setup
+}
+
src_prepare() {
default
rm tests/schema/{definitions,ref{,Remote}}.json || die
@@ -42,8 +46,6 @@ src_prepare() {
}
src_configure() {
- use lua && lua_setup
-
local myeconfargs=(
"$(use_enable lua)"
"$(use_enable regex)"
diff --git a/dev-libs/libucl/libucl-9999.ebuild b/dev-libs/libucl/libucl-9999.ebuild
index 2eb9fa97c158..8b3e4c0b5cc2 100644
--- a/dev-libs/libucl/libucl-9999.ebuild
+++ b/dev-libs/libucl/libucl-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -35,6 +35,10 @@ RDEPEND="${DEPEND}"
DOCS=( README.md doc/api.md )
+pkg_setup() {
+ use lua && lua_pkg_setup
+}
+
src_prepare() {
default
rm tests/schema/{definitions,ref{,Remote}}.json || die
@@ -42,8 +46,6 @@ src_prepare() {
}
src_configure() {
- use lua && lua_setup
-
local myeconfargs=(
"$(use_enable lua)"
"$(use_enable regex)"