summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2018-10-30 12:29:19 +0100
committerMichał Górny <mgorny@gentoo.org>2018-11-10 19:15:44 +0100
commit45ff96c4367498d70f3c449f199b05462d088d38 (patch)
tree3a776e5b14d9a27ffe0e0af7bccecb700703a064 /dev-libs
parentapp-misc/mx5000tools: New package (diff)
downloadgentoo-45ff96c4367498d70f3c449f199b05462d088d38.tar.gz
gentoo-45ff96c4367498d70f3c449f199b05462d088d38.tar.bz2
gentoo-45ff96c4367498d70f3c449f199b05462d088d38.zip
dev-libs/libugpio: New package
Libugio is a library to easy the use of linux kernel's sysfs gpio interface from C programs and/or other libraries. Closes: https://bugs.gentoo.org/667798 Signed-off-by: Conrad Kostecki <conrad@kostecki.com> Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libugpio/Manifest1
-rw-r--r--dev-libs/libugpio/libugpio-0.0.6.ebuild30
-rw-r--r--dev-libs/libugpio/metadata.xml21
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-libs/libugpio/Manifest b/dev-libs/libugpio/Manifest
new file mode 100644
index 000000000000..b401fa766438
--- /dev/null
+++ b/dev-libs/libugpio/Manifest
@@ -0,0 +1 @@
+DIST libugpio-0.0.6.tar.bz2 252283 BLAKE2B ebdfae8ef400b3deb95e4313fd0ca2ad7b195945c850ce5c84904373bca2f2c9d446aec45b0500f549ab5319a294fbc2f0c37a6734fab69d8571389a0cb5fb63 SHA512 f40517d34509f9f3b5b26a5cb5523863034d48887ef3f26bd38a38e9aeac73e09ecf71099cd5a036e23fe3db5c8c2ead588c49022a398f2a426bc7148cc64ecd
diff --git a/dev-libs/libugpio/libugpio-0.0.6.ebuild b/dev-libs/libugpio/libugpio-0.0.6.ebuild
new file mode 100644
index 000000000000..f48a044c9827
--- /dev/null
+++ b/dev-libs/libugpio/libugpio-0.0.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info
+
+DESCRIPTION="Lib for the use of linux kernel's sysfs gpio interface from C programs"
+HOMEPAGE="https://github.com/mhei/libugpio"
+SRC_URI="https://github.com/mhei/${PN}/releases/download/v${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-3+ LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+CONFIG_CHECK="~CONFIG_GPIO_SYSFS"
+
+src_configure() {
+ local myeconfargs=(
+ --disable-static
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/dev-libs/libugpio/metadata.xml b/dev-libs/libugpio/metadata.xml
new file mode 100644
index 000000000000..1340ccfdad65
--- /dev/null
+++ b/dev-libs/libugpio/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ck+gentoo@bl4ckb0x.de</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ Libugpio is a free software library to ease the use of linux kernel's sysfs
+ gpio interface from C programs and/or other libraries.
+ The basic function set is derived from the kernel internal gpio api.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/mhei/libugpio/issues</bugs-to>
+ <remote-id type="github">mhei/libugpio</remote-id>
+ </upstream>
+</pkgmetadata>