summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-10-26 09:37:12 +0200
committerMichał Górny <mgorny@gentoo.org>2018-10-26 10:38:44 +0200
commit4b0696fc3af3de2e954e06c90fd6842924cc0c6f (patch)
treeb5414ced3ed9088458df42300181172458740a8a /dev-libs
parentnet-irc/eggdrop: remove ancient version (diff)
downloadgentoo-4b0696fc3af3de2e954e06c90fd6842924cc0c6f.tar.gz
gentoo-4b0696fc3af3de2e954e06c90fd6842924cc0c6f.tar.bz2
gentoo-4b0696fc3af3de2e954e06c90fd6842924cc0c6f.zip
dev-libs/libgit2-glib: Bump to 0.26.4, the meson version
Bump to 0.26.4. The new version features replacing the build system with meson, and renaming the vala package. It is needed to build new dev-vcs/gitg. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libgit2-glib/Manifest1
-rw-r--r--dev-libs/libgit2-glib/libgit2-glib-0.26.4.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-libs/libgit2-glib/Manifest b/dev-libs/libgit2-glib/Manifest
index 68a7f94f1f12..c393ca48882b 100644
--- a/dev-libs/libgit2-glib/Manifest
+++ b/dev-libs/libgit2-glib/Manifest
@@ -1 +1,2 @@
DIST libgit2-glib-0.26.2.tar.xz 421956 BLAKE2B d38698f00d85b484d17078e78ad051a4c068b87df73fcf4d7b852dc6966628580cc4e5b3899a6edd5dc29fb47ef97ebe2c458992701b7642549f3e411d917dc5 SHA512 35fb3ec7a3757212f53cc884760f69725beff8462018b8e716fad389ba57d1acba99ece0fcd148ff40dc63e1fc7e7d566fe84759bd88d3a0ff9fdf970b0a5563
+DIST libgit2-glib-0.26.4.tar.xz 138492 BLAKE2B 725c14076fb940186faac079cff1ea87c456ed41e943ae95a4a674632c1be261ab6d4d5bcb5c0800bbde5d86c1ff3095d59045a2fda1342a1cf5c691a2b424aa SHA512 9eb78f292583862890ca0cd27d7621da2f8f633a76f4679f897ce6cf9e06b64a3cb7b0ddda39d231d21d3faa830fe1a9a9326b4abd420df8356d50a734360b37
diff --git a/dev-libs/libgit2-glib/libgit2-glib-0.26.4.ebuild b/dev-libs/libgit2-glib/libgit2-glib-0.26.4.ebuild
new file mode 100644
index 000000000000..28f3698ede9d
--- /dev/null
+++ b/dev-libs/libgit2-glib/libgit2-glib-0.26.4.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{3_4,3_5,3_6,3_7} )
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome.org meson python-r1 vala
+
+DESCRIPTION="Git library for GLib"
+HOMEPAGE="https://wiki.gnome.org/Projects/Libgit2-glib"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="python +ssh +vala"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+# Specify libgit2 dependency with subslot because libgit2 upstream has a habit
+# of changing their API in each release in ways that break libgit2-glib
+RDEPEND="
+ >=dev-libs/gobject-introspection-0.10.1:=
+ >=dev-libs/glib-2.44.0:2
+ >=dev-libs/libgit2-0.26.0:0/26[ssh?]
+ python? (
+ ${PYTHON_DEPS}
+ dev-python/pygobject:3[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ dev-util/glib-utils
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ default
+ use vala && vala_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ # apparently broken; fails to build
+ -Dgtk_doc=false
+ # we install python scripts manually
+ -Dpython=false
+ -Dssh=$(usex ssh true false)
+ -Dvapi=$(usex vala true false)
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ if use python ; then
+ python_moduleinto gi.overrides
+ python_foreach_impl python_domodule libgit2-glib/Ggit.py
+ fi
+}