summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Strogin <steils@gentoo.org>2019-05-24 11:27:42 +0300
committerStefan Strogin <steils@gentoo.org>2019-05-24 11:36:26 +0300
commit5384e86a42d6e3f3f6eeff7e44a9f76aa3ce02b7 (patch)
tree4792c6ed87e59b3e2307dc285108914a9b350136 /dev-libs
parentmail-mta/protonmail-bridge-bin: 1.1.5 version bump. (diff)
downloadgentoo-5384e86a42d6e3f3f6eeff7e44a9f76aa3ce02b7.tar.gz
gentoo-5384e86a42d6e3f3f6eeff7e44a9f76aa3ce02b7.tar.bz2
gentoo-5384e86a42d6e3f3f6eeff7e44a9f76aa3ce02b7.zip
dev-libs/libressl: fix compilation on non-glibc systems
Reported-by: Philipp Ammann <philipp.ammann@posteo.de> Closes: https://github.com/gentoo/gentoo/pull/12078 Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Stefan Strogin <steils@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libressl/files/libressl-2.9.2-non-glibc.patch32
-rw-r--r--dev-libs/libressl/libressl-2.9.2.ebuild1
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-libs/libressl/files/libressl-2.9.2-non-glibc.patch b/dev-libs/libressl/files/libressl-2.9.2-non-glibc.patch
new file mode 100644
index 000000000000..b00316d88141
--- /dev/null
+++ b/dev-libs/libressl/files/libressl-2.9.2-non-glibc.patch
@@ -0,0 +1,32 @@
+From a9f0b2143c3154da34b8798127263f6f11f61bd5 Mon Sep 17 00:00:00 2001
+From: Ishimoto Shinobu <47295761+protonesso@users.noreply.github.com>
+Date: Tue, 21 May 2019 22:41:05 +0900
+Subject: [PATCH] avoid glibc
+
+cause problems on musl systems
+
+Upstream-Status: Backport
+[https://github.com/libressl-portable/portable/pull/529]
+Signed-off-by: Stefan Strogin <steils@gentoo.org>
+---
+ crypto/compat/getprogname_linux.c | 4 +---
+ 1 file changed, 1 insertion(+), 3 deletions(-)
+
+diff --git a/crypto/compat/getprogname_linux.c b/crypto/compat/getprogname_linux.c
+index 2c89743..4e7e31f 100644
+--- a/crypto/compat/getprogname_linux.c
++++ b/crypto/compat/getprogname_linux.c
+@@ -26,9 +26,7 @@ getprogname(void)
+ #if defined(__ANDROID_API__) && __ANDROID_API__ < 21
+ extern const char *__progname;
+ return __progname;
+-#elif defined(__GLIBC__)
+- return program_invocation_short_name;
+ #else
+-#error "Cannot emulate getprogname"
++ return program_invocation_short_name;
+ #endif
+ }
+--
+2.21.0
+
diff --git a/dev-libs/libressl/libressl-2.9.2.ebuild b/dev-libs/libressl/libressl-2.9.2.ebuild
index b9ba51552c33..41f5f416b1b9 100644
--- a/dev-libs/libressl/libressl-2.9.2.ebuild
+++ b/dev-libs/libressl/libressl-2.9.2.ebuild
@@ -41,6 +41,7 @@ src_prepare() {
fi
eapply "${FILESDIR}"/${PN}-2.8.3-solaris10.patch
+ eapply "${FILESDIR}"/${P}-non-glibc.patch
eapply_user
elibtoolize # for Solaris