summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2018-02-12 20:11:59 +0100
committerDaniel Pielmeier <billie@gentoo.org>2018-02-12 20:12:23 +0100
commit55b96c727287728374a11de48028112417dbded5 (patch)
tree185e774c898329bffbea42b49a44ded309a997a8 /dev-libs
parentdev-ada/aws: dev-ada/gnat_util use static -> static-libs (diff)
downloadgentoo-55b96c727287728374a11de48028112417dbded5.tar.gz
gentoo-55b96c727287728374a11de48028112417dbded5.tar.bz2
gentoo-55b96c727287728374a11de48028112417dbded5.zip
dev-libs/libburn: Revision bump.
Remove the track-src-odirect USE flag. This flag causes burn failures when reading from a data file. More information at https://bugs.kde.org/show_bug.cgi?id=257602 Package-Manager: Portage-2.3.19, Repoman-2.3.6 RepoMan-Options: --force
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libburn/libburn-1.4.8-r2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-libs/libburn/libburn-1.4.8-r2.ebuild b/dev-libs/libburn/libburn-1.4.8-r2.ebuild
new file mode 100644
index 000000000000..e18746798c9e
--- /dev/null
+++ b/dev-libs/libburn/libburn-1.4.8-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Open-source library for reading, mastering and writing optical discs"
+HOMEPAGE="https://dev.lovelyhq.com/libburnia/web/wikis/home"
+SRC_URI="http://files.libburnia-project.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 sparc x86"
+IUSE="debug static-libs"
+
+RDEPEND=""
+DEPEND="$RDEPEND
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ --disable-ldconfig-at-install \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+
+ dodoc CONTRIBUTORS doc/{comments,*.txt}
+
+ docinto cdrskin
+ dodoc cdrskin/{*.txt,README}
+ docinto cdrskin/html
+ dodoc cdrskin/cdrskin_eng.html
+
+ find "${D}" -name '*.la' -delete || die
+}